Need help importing spray logos...

#1SnowFox7Posted 3/19/2011 5:07:02 AM
Okay, so I've always played the L4D games on the xbox, so I'm new to the whole spray logo feature. I'm hooked on steam though, the xbox just keeps letting me down and I'm tired of missing out on the extra community content and such.

Anyways, so I'm trying to get the custom spray logos to work, and I just can't figure it out. At first I got the image corrupt thing, so I googled it and set the pixel size to 256 by 256, and stopped getting those errors.

Now, when I try to select a custom spray, I select it from the open file browser that pops up, and it just does nothing, and picks the default coach spray. No errors or anything, and I tried it out in game thinking maybe it just doesn't register, but no, definitely not working.

I also tried converting the pics to pretty much everything, vtf or w/e that type is, via a converter specifically for valve games, along with vga from the photoshop plugin I downloaded, again, specifically meant to work for this. I also tried jpg, bmp 24 bit, gif, png, and I think a couple others. I fiddled with the 'spray with alpha' settings in the photoshop plugin, both the ones the tutorials I followed said to use, and others when that failed.

Lastly, I tried downloading some already made ones from a site meant just for spray logos.... Nothing... I'm really at a loss, and I feel like I'm missing something stupidly obvious here. All the guides and youtube vids I've seen show it just working, and it just won't for me. The option for disallowing community content is off, and I've seen other people use sprays in game with no issues, so idk wth is wrong.

So.. Anyone have a helpful tip or two, or can take a guess at what I'm doing wrong here? I really do feel like it's something really obvious, but none of the guides I found mentioned it, and I followed several of them to the letter. x.x
#2STG DeathbotPosted 3/19/2011 11:51:36 AM
Did you put the spray in the ...\Valve\Steam\SteamApps\common\left 4 dead 2\left4dead2\materials\vgui\logos folder as well as the ...\Valve\Steam\SteamApps\common\left 4 dead 2\left4dead2\materials\vgui\logos\UI folder? Then did you enable it via the options menu and make sure your spray was displayed in the options menu under the preview section before continuing on to a game?
---
Wolfdale e8400 @ 3.6GHz OC'd | 4GB Mushkin RAM | eVGA GTX 260 896MB VRAM 576/1242/1998 OC'd to 732/1457/2360
#3SnowFox7(Topic Creator)Posted 3/19/2011 12:29:41 PM
Hrmm, I only put it in the logos folder, not the UI folder... And it wasn't showing up in the options, only the option to import a pic which did nothing. I'll try that out now though.

...

Ahh, nope, still nothing... Just keeps selecting the default coach pic...

Geez, so annoyed with this. Thx for replying though, but maybe i'm just jinxed lol. x.x

What bugs me is that all those video guides make it look so easy, a couple clicks and it's done.. No idea why I'm having so much trouble with it. ;/
#4diamond weaponPosted 3/19/2011 1:21:26 PM(edited)
Put yourspray.vtf file in the ...\logos folder. Then launch L4D2, and instead of trying to select it directly, go to Import Spray, navigate to, and import the vtf file you just made. That will cause the game to generate the necessary yourspray.vmt file, which will cause the spray to properly appear in the menus.

If nothing works, and you also own another Source game, like TF2 or CS:S, you can alternatively use that game's spray importer. Mostly the same procedure: place vtf in logos folder, import spray in-game, exit game, navigate to logos folder, copy matching vtf and vmt pair, place in L4D2's ...\logos\custom folder.

You could always upload the image you're trying to convert, and one of us could handle it, too.

---
I'd like to shake the hand of whoever marked this topic for "other: beating a dead horse" ~ Cheradenine
#5RainingMetalPosted 3/19/2011 1:42:33 PM
I thought it had to be in TGA format.
---
http://www.youtube.com/watch?v=8cJNpPN6AO8
Steam Account: http://steamcommunity.com/profiles/76561197964001631
#6diamond weaponPosted 3/19/2011 2:00:00 PM(edited)
Sometimes, a particular game's spray importer will bug out and not properly convert a particular filetype, but a VTF file will always properly import. Also, as far as I'm aware, you need it in VTF format for animated sprays.
---
Any sufficiently advanced technology is indistinguishable from magic ~ Arthur C. Clarke
#7NeoBasiliskPosted 3/19/2011 2:09:31 PM
It can be a jpg too. Just make sure it's 256x256, and import it. Done.
---
http://img384.imageshack.us/img384/2505/toonami0003by7.jpg
RIP Toonami (1997-2008)
#8STG DeathbotPosted 3/19/2011 10:12:42 PM
I can't ever get anything except a .vtf to work.
---
Wolfdale e8400 @ 3.6GHz OC'd | 4GB Mushkin RAM | eVGA GTX 260 896MB VRAM 576/1242/1998 OC'd to 732/1457/2360
#9SnowFox7(Topic Creator)Posted 3/19/2011 11:39:36 PM
Okay, first of all, everything I tried was 256 x 256, except one batch of pics which I made 128 x 128 or w/e the second largest allowable size was. I've also tried making .jpg, .vtf, .tga, .png, .gif, .bmp (24 bit), as well as making those then converting to other files back and forth. Like I said I used the converter meant for this very purpose to make vtf files, the photoshop plugin, etc.

On top of all that I did to make pics that would work, I also downloaded several from gamesprays.com, in various formats, a couple of which were vtf files with the vmt file to go with it. I even edited one of the default pics to see if the changes showed up, and still nothing.

I don't understand why nothings working, but after seeing so many people in guides and forums get it working with no issues, I've drawn the conclusion that the actual picture file is not the problem. But, just for the sake of being sure, if anyone has a vtf with vmt that they are 100% positive will work, I'd love if you could upload it so I could try it for testing to see if it even works, I don't care what picture it is, I won't actually use it, I just wanna get this working.

From what I've seen in guides and video guides, it looks like the dropdown selection menu should either contain the non-default sprays you've added, or a "custom spray" option at the bottom. That doesn't exist on mine though. I sent a msg about it to steam support a couple days ago, but they haven't responded, and it looks like they probably won't. Oh and before I forget, I also downloaded the "addon support" from the tools section of steam for L4D2, because one of the guides said I need that. I also tried the console commands cl_allowdownload and upload set to 1, failing all else, which also didn't work. And I also tried making a vmt file manually with notepad, which also didn't work.

Like seriously, I don't know if this is just bugged or what, but those guys should really not make it this finicky to import a simple picture file.

Anyways, thx for the replies, and if you guys think of anything else I'd love to hear it, as I really want to get this working. I don't have any other games on steam that I could test this with unfortunately, but you guys have already been a lot more help then the steam staff, so again, if you think of anything else at all worth trying, I'll try it lol. I'm out of things to try, and all the guides I find on google just keep repeating the same stuff that doesn't work... Which sucks because it seems to work fine for everyone else. :(
#10SnowFox7(Topic Creator)Posted 3/20/2011 11:40:38 AM
Tried some other things, still nothing...

So... I take it this is just broke for me for whatever reason, eh? Is there a way to reinstall L4D2 without re-downloading it? And also, could it be that the reason it's broke is because I downloaded the game through steam, instead of buying it on disc?