Fallout 3 Game Of The Year Eddition: Disc 2: DLC Not Installing

#1ARavinMadMonkeyPosted 12/31/2009 4:31:15 AM
Hi, im new to these fourms and i guess this is in the right place.

Anyway I Have Fallout 3 Game Of The Year Eddition,when i start up the disc it says theres an update (this has happened multiple times now) I Click "Yes Update Now" And A Box Comes Up Sating Install Expansion Pack, there was no sign of the updaye being complete, next... i go to install the 5 DLC's but when i click Install Selected the bar starts and stops, and restarts 2 or 3 times and then a message pops up saying "Can't Install One Or More Items" I Click OK on that and another box comes up saying "Finish And Eject Disc" And In Small Letters It Says "Insert your game disc to play the game" And thats it

Can Anyone help me if you have had the same problem or you just know how to fix it , Ive taken the game back and got a new one but the same still happens, my memory should be ok ive still got about 6 Gig left. Thanks For All The Help
ARavinMadMonkey
#2Knight2520Posted 12/31/2009 11:06:23 AM
That sounds like it's your Xbox 360. Your disc drive may be crapping out on you.
---
Xbox LIVE Gamertag: Onyx Spartan II
Winter is coming.
#3ChimChimenyPosted 1/12/2010 11:26:04 AM
dont be so quick to assume a faulty disc drive. i'm having the exact same problem, i ofcourse assumed disc drive too but after testing it is fine so its not that.

i have had slightly more success than the topics author as somehow anchorage seems to have installed ok, but on the install disc the other 2 dont work, and im not even sure why all 5 dont show up so that may be just an extra problem im having..
#4Knight2520Posted 1/12/2010 7:38:57 PM
Testing it with what, other games? That hardly means anything. When my drive started to fail, it failed only with one game. Then two. Then every game I had, over a period of several months.
---
Xbox LIVE Gamertag: Onyx Spartan II
Lethal force engaged!
#5ChimChimenyPosted 1/12/2010 8:39:07 PM
no by testing i meant the disc works in my mates xbox, but not mine.

it is ofcourse possibly the drive packing in but im looking for anyone with a similar problem that has found a solution before i go replacing my xbox altogether.
#6Knight2520Posted 1/12/2010 8:43:01 PM
So the second disc works in your friend's 360, but not yours. That proves my point that it could be your disc drive.
---
Xbox LIVE Gamertag: Onyx Spartan II
Lethal force engaged!
#7ChimChimenyPosted 1/14/2010 10:18:45 AM
went out and bought a new xbox today, whacked my harddrive in it, still the same problem, not a drive problem >_>
#8Knight2520Posted 1/14/2010 1:40:36 PM
Well, that's different then. I guess a new GOTY is in order.
---
Xbox LIVE Gamertag: Onyx Spartan II
Lethal force engaged!
#9ChimChimenyPosted 1/16/2010 4:16:52 PM
was gonna send the disc back to shopto but all the disc failed as resulted in it getting ringed so no returns for me. anchorage is the only one that worked off of the disc for whatever reason so i just bought the other 4 over XBL since that worked out about a fiver cheaper.

i guess its a better result than a bricked xbox i suppose, still a bit peeved though.