stuck on KAFFAROV ...Pool House (spoilers)

#1silverfaustxPosted 10/25/2011 6:41:11 PM
im making this topic, because ALOT of ppl will get stuck on the level

spoiler :












shoot him before he shoots u, its that or game over
kil the american to save america !
#2FreelancePosted 10/25/2011 8:47:46 PM
How could you get stuck? The speech before it leads up to the outcome pretty obviously.

I got stuck hard at..... SPOILERS














-----
Guy at villa escaping in the helicopter. I shot it sooo many times, pieces were falling off, but he still flew away every time. Eventually I realized I had to RUN UP to the chopper and climb on, NOT SHOOT IT DOWN TO DISABLE IT. Made me chuckle.
---
Unofficial Underground Car Tuning/Street Racing Board
http://boards.gamefaqs.com/gfaqs/gentopic.php?board=585168
#3FlakconPosted 10/26/2011 5:14:55 AM
Problem is... I CANT SHOOT HIM
---
PSN: theSkarekro BNET: theSkareqro
My SSF4:AE videos http://www.youtube.com/user/theSkarekro
#4thyco1241Posted 10/26/2011 5:47:00 AM
i have the same problem, i cant shoot my CO after dimiti gives his little speech
#5silverfaustx(Topic Creator)Posted 10/26/2011 6:31:43 AM
i never even tought about shooting him..but after i found out and it become more obvious to me, it made more sense

but even if u know, shooting him takes timing, hit him while he is stil on the stairs
#6GraevesPosted 10/26/2011 6:38:56 AM
Just click like mad after the speech you get... Had to do it 4 times in a row before I finally shot the guy...
---
"It's not about black or white because we're human." - Tupac Shakur
#7silverfaustx(Topic Creator)Posted 10/26/2011 6:55:37 AM
hate it that u cant skip those stupid cutscenes
#8FlakconPosted 10/26/2011 6:59:00 AM
I can't shoot him AT ALL. Even when spamming
---
PSN: theSkarekro BNET: theSkareqro
My SSF4:AE videos http://www.youtube.com/user/theSkarekro
#9silverfaustx(Topic Creator)Posted 10/26/2011 7:19:15 AM
try to aim at him and mashing left right mouse buttons,as soon as u see him
#10FlakconPosted 10/26/2011 10:18:19 AM
I tried that for 10+ times before I said "F it" and restarted the whole level.
Worked on the first try after... Definitely a glitch
---
PSN: theSkarekro BNET: theSkareqro
My SSF4:AE videos http://www.youtube.com/user/theSkarekro