ATI card issue??

#1jeremy42069Posted 5/22/2011 9:20:34 AM

I just got my copy of the witcher 2 and got it installed. When I go to load up the game everything looks fine intro, start title and first lines of the game appear normal. When it gets to the opening part where Geralt is running from people everything is blue and when hes in the dungeon everything is orange. Its just blured color and you can hardly make out the shapes. I have an Alienware Area 51 rig with i7960 CPU12GBram and single ATI Radeon HD 5970 2GB video card and latest driver.Also my OS is Windows 7 64bit. I know this computer should defineatly be able to run this game. Any suggestions?

#2istuffedsunnyPosted 5/22/2011 9:25:46 AM
Hey Gator colors! Take some screens, it sounds awesome.
#3CYBORG112Posted 5/22/2011 9:31:12 AM
Try updating your drivers. When updating drivers make sure you get rid of the old one first completely.

Uninstall everything first driver/ccc/install manager etc. Download Drivercleaner and run it in the safemod of windows, delete everything that says ATI on it. After that you can boot back into normal windows and install new drivers.
---
|| i72600k @ 4.5Ghz || Gigabyte P67A-UD4-B3 || Scythe Ninja 3 || HAF 932 FullTower || G.Skill Ripjaws x 8GB 1866Mhz || Asus GTX580 DCII @ 902/1804/2153 ||
#4llkPosted 5/22/2011 9:31:54 AM
I'm not expert (maybe someone can help confirm), but I would try to roll back your driver on the video card. Everything I have read recently seems to suggest that the most recent drivers have 3d attached to them and its screwing up a lot of things.

I hope this helps!
#5CYBORG112Posted 5/22/2011 9:34:01 AM
llk posted...
I'm not expert (maybe someone can help confirm), but I would try to roll back your driver on the video card. Everything I have read recently seems to suggest that the most recent drivers have 3d attached to them and its screwing up a lot of things.

I hope this helps!


Yeah that sounds like a good idea too. If the new drivers dont work out , rolling back is soemthing to try.
---
|| i72600k @ 4.5Ghz || Gigabyte P67A-UD4-B3 || Scythe Ninja 3 || HAF 932 FullTower || G.Skill Ripjaws x 8GB 1866Mhz || Asus GTX580 DCII @ 902/1804/2153 ||
#6popredPosted 5/22/2011 9:40:02 AM
Set your 3D graphics to either balanced or high performance or optimal performance in the CCC. ATI cards are having driver issues which will be resolved soon.
#7ShieftainPosted 5/22/2011 9:42:41 AM
It's possible that you have anti aliasing forced from your catalyst control center. My game looked similar to yours when I tried to force AA. Just turn it off, and you should be good to go.
---
"Why must the good die young?!" - Sheen, from Jimmy Neutron, Boy Genius
#8RyuHoshi87Posted 5/22/2011 9:49:39 AM
I have a 4870 and this game runs fine.
---
"Even though you'll never be perfect, you shine in your imperfection." -Ayumi Hamasaki
#9TheBaldAdeptPosted 5/22/2011 9:53:21 AM
I had exactly the same problem. Go into your catalyst control centre and check the AA box that says "use applications settings" or something like that. The problem is caused by catalyst forcing AA.
---
Is this a question?
#10jeremy42069(Topic Creator)Posted 5/22/2011 9:55:54 AM

I resolved the issue. Thanks popred I set my card to Optimal performance and immedieatly it fixed the issue. Now I can play the Witcher all day. Thank you very much.