Problem with keyboard or controller?

#1Travis281Posted 9/24/2010 5:54:43 PM

When I get to the game's menu the cursor is moving itself up the menu selections as though I were holding the up arrow on my keyboard. If I have my 360 controller plugged in the cursor is moving up, but twice as fast. If I manage to load the game I am stuck staring at the ground.

I have a Saitek Eclipse keyboard which has caused me problems, but only with Trackmania. All other games work fine and I don't have a secondary keyboard to test. Running Windows 7 x64.

#2Travis281(Topic Creator)Posted 9/24/2010 10:53:45 PM

Ok well, I just wanted to say that the problem has been solved. Apparently the game will not function whilst my Saitek Eclipse keyboard is plugged into my computer. This has to be the silliest computer incompatibility problem I have ever encountered. I simply plug my 360 controller in and unplug my keyboard and I can play just fine.

#3virdicyerPosted 9/26/2010 1:39:01 PM
It also doesn't work with my PS2 controller -- it stays looking at the sky. It won't let me change the controls, it thinks my PS2 controller is a dumb Xbox controller.
---
-Whatever challenges you, makes you stronger.
#4Ultima_D_StrikePosted 9/26/2010 1:50:44 PM
i have the same problem with my gamepad it also keeps facing up or down.
gotta say this is the first game where my gamepad doesn't work well it really has to do with this being a bad port.
---
Te veel teringlijers op gamefaqs!
#5DaringRiderPosted 9/29/2010 4:06:42 AM
Go here:code.google.com/p/x360ce/wiki/MainPage
download new updated C++ Redistributable package and install it. now download the .zip file from download section.
upzip it.there should be a .exe file.run it.It may asked for a "xinput1_3.dll" file and "xbox360ce.ini" file.clik "yes" to create them.A nice GUI will load up.Load your controller.configure buttons if some goes odd.
Clik "save". and exit the application.Now copy the .dll and .ini and .exe file to darksider main installation folder.
Now you should use your gamepad with no problem
#6xts3Posted 9/29/2010 8:29:14 AM

DaringRider posted...
Go here:code.google.com/p/x360ce/wiki/MainPage download new updated C++ Redistributable package and install it. now download the .zip file from download section. upzip it.there should be a .exe file.run it.It may asked for a "xinput1_3.dll" file and "xbox360ce.ini" file.clik "yes" to create them.A nice GUI will load up.Load your controller.configure buttons if some goes odd. Clik "save". and exit the application.Now copy the .dll and .ini and .exe file to darksider main installation folder. Now you should use your gamepad with no problem

Problem is using that method causes the game to crash intermittently.

#7DaringRiderPosted 9/29/2010 9:15:47 AM
i dint had any problem like tat...it works for me
#85eph1r0thPosted 10/4/2010 2:20:04 AM

hey man i have the same problem with my logitech rumblepad2 controller on darksiders it keeps looking up

did u find a solution??

#9RaihazanPosted 10/4/2010 6:40:12 AM

From: xts3 | #006
Problem is using that method causes the game to crash intermittently.


Disable force feedback in the options. Worked like a charm for me.
#10RaihazanPosted 10/4/2010 6:42:23 AM
Just to be clear: Disable force feedback in X360CE

Also if anyone has problem getting X360CE to work at all make sure you have it in the main folder where Darksiders is installed.