3D glasses should be required.

  • Topic Archived
  1. Boards
  2. Nintendo 3DS
  3. 3D glasses should be required.
5 years ago#71
onlive is basically the same thign as installing a hardware upgrade, except its in software, u run ur games in the new software/hardware, they max crisis
---
member of the sam jackson alliance
maybe even the president ^m i rite
5 years ago#72
Ignore the rest of my post. As with this one.

You are a trooooooooooooooooooooooooooooooooooooll.
---
If the game gets a bad score, bash the game; if the game gets a good score, bash the reviewer. - stanthelovebot
Buy these: Klonoa (Wii), Fragile Dreams,
  1. Boards
  2. Nintendo 3DS
  3. 3D glasses should be required.

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived