Error 006-0612

#1Crums44Posted 3/29/2013 9:26:52 PM
Ever since my family purchased a new modem since we moved houses (Technicolor TG587n v3) I have been able to connect my 3DS to the internet and do everything except online play on games, including MK7, Mario Tennis Open, and most recently, Luigi's mansion 2. I am able to connect to the network but I am unable to find players, join games, or start any games as I am interrupted by Error 006-0612.

I've google'd the issue and tried to find solutions, but I can't seem to find a solid answer to fix the error with THIS particular modem.

Does anyone know a source that will show me steps I can take to get it working with this modem? Any help would be GREATLY appreciated.
---
SSBB: Yoshi! Brawl FC 5069-5391-3912. Dream Games:
Sonic Adventure 3, Pokemon Stadium 3, Banjo Threeie
#2Crums44(Topic Creator)Posted 3/30/2013 4:35:44 PM
Bump
---
SSBB: Yoshi! Brawl FC 5069-5391-3912. Dream Games:
Sonic Adventure 3, Pokemon Stadium 3, Banjo Threeie
#3KurizakaPosted 3/30/2013 4:52:05 PM
Tried doing a little searching and I found this - "Check your WiFi Settings and make sure they are correct. If in doubt, try resetting your modem to factory settings and choosing WPA as the encryption type". Have you tried this? I'm not exactly sure how to do things like this, but I hope this somehow helps.
#4CarCrashClutterPosted 3/30/2013 5:01:56 PM
Are other devices working fine over wifi?

If they are, I'd start with logging into the modem and setting the 3DS's IP address to be DMZ. If that lets you play online fine, you can either leave it that way or you can turn DMZ off and turn on uPnP since it'll probably be a port problem that's keeping games from connecting.
#5Crums44(Topic Creator)Posted 3/31/2013 5:55:43 PM
Kurizaka posted...
Tried doing a little searching and I found this - "Check your WiFi Settings and make sure they are correct. If in doubt, try resetting your modem to factory settings and choosing WPA as the encryption type". Have you tried this? I'm not exactly sure how to do things like this, but I hope this somehow helps.


I have tried this but thanks anyway. I am also not sure how to do things like this either which makes it all the more confusing for me too!

CarCrashClutter posted...
Are other devices working fine over wifi?

If they are, I'd start with logging into the modem and setting the 3DS's IP address to be DMZ. If that lets you play online fine, you can either leave it that way or you can turn DMZ off and turn on uPnP since it'll probably be a port problem that's keeping games from connecting.


I have logged into the modem, and I have checked around the firewall settings, and I found my 3DS, but I see no option allowing me to set the 3DS's IP to DMZ. I tried turning on uPnP but that didn't work either :s

And Yes-- other devices are working fine over wi-fi. with the DS, I can connect to the internet still, and use eShop, 3DS updates, and internet browser. I just cannot play any games over wifi thanks to this error.
---
SSBB: Yoshi! Brawl FC 5069-5391-3912. Dream Games:
Sonic Adventure 3, Pokemon Stadium 3, Banjo Threeie
#6KurizakaPosted 3/31/2013 6:00:26 PM
You're welcome. I hope you're able to find a fix. Have you tried contacting Nintendo? Maybe they'll have an answer.
#7Crums44(Topic Creator)Posted 3/31/2013 7:32:56 PM
Kurizaka posted...
You're welcome. I hope you're able to find a fix. Have you tried contacting Nintendo? Maybe they'll have an answer.


Well after discussing it with the family I think we will just end up getting a new router. This one kind of sucks anyway.
---
SSBB: Yoshi! Brawl FC 5069-5391-3912. Dream Games:
Sonic Adventure 3, Pokemon Stadium 3, Banjo Threeie
#8KurizakaPosted 3/31/2013 7:34:20 PM
Crums44 posted...
Kurizaka posted...
You're welcome. I hope you're able to find a fix. Have you tried contacting Nintendo? Maybe they'll have an answer.


Well after discussing it with the family I think we will just end up getting a new router. This one kind of sucks anyway.


That would work.
#9CarCrashClutterPosted 3/31/2013 9:19:28 PM
I googled "Technicolor TG587n v3 3ds issues" and there's a few threads across a couple sites that have the same issue. Some people recommend turning off NAT. This thread talks about it http://crowdsupport.telstra.com.au/t5/Modems-Hardware/Turn-off-NAT-on-a-Technicolor-TG587n-v3/td-p/18340 This Youtube vid covers the actual steps (gotta use Telnet) http://www.youtube.com/watch?v=4gNkFRlvah4

Your solution is probably the best though.