Question from Areiya

Asked: 6 years ago

Why do I DC as soon as the load screen ends?

For the past two months, randomly when I try logging in on a toon I get DC'd back to the log in screen just as the load screen fills. Apparently I show up in game but my screen never gets that far. Once that happens Im usually locked out of my other main. If I'm lucky, logging into an alt helps. I'm running Windows XP...any ideas what's causing this or how to fix it?

Additional details - 6 years ago

Thanks for the feedback. Verizon DSL. My connection isnt cutting out whenever this happens though. Nothing had changed to my connection when it started. It was right after a pre expansion patch, dont know which exact one. Im leaning away from connection because I'll try my main several times in a row and no go, try an alt and it's fine, go back to the main and no go. But I can play the alt with no connection issues whatsoever, like I'm just locked out of one toon. It also only happens after I've been in game for a while and try switching to one then back. The load bar also sits at full longer on the toon I'm getting DC'd from than any others I'll try at the same time.

Additional details - 6 years ago

Also tried deleting cache, wtf, and interface like Blizz suggests and still no improvement.

Top Voted Answer

From: toraoji 6 years ago

The most likely culprit is the questhelper addon. I've had this problem alot (especially in dalaran) and it is always fixed by turning off questhelper.

to quote the GM who first helped me figure this out "that mod has more bugs than an ant farm.

Rated: +2 / -0

This question has been successfully answered and closed

Submitted Answers

STATUS

Mkay. what connection are you using? you may wanna think about either resetting or downright replacing your internet connection. this has nothing to do with your computer if your are just getting disconnected.

Rated: +0 / -1

Any addons that you're using? If so, make sure of course that all are updated.

Rated: +0 / -0

do you have a firewall or some sort of security software set up? i was playing wow w/ mcafee (sorry if spelling is wrong) for about a year. in that year i basically could not raid, and i would constantly get d/c. this sounds at least similar to your problem.

if you are playing w/ this sort of software "on," i would at least tinker w/ disabling it and seeing what happens when you load up WoW.

Rated: +0 / -0

Sounds like an addon to me, disable them all and see if it works then. If so, it's just a process of elimination then to try find the dodgy one and update/remove it.

Rated: +0 / -0

I have been having this problem laltely in Dalaran a lot.

The only way that I have found is to either disable all of your addons, or get on another character and cut your graphics way down (especially view distance and any other distance or texture graphics) and try again on the original character. What is happening is, you are loading, then the game loads your character in game, but your computer hasn't finished loading the zone and all its graphics yet. Although you see the loading screen, the game thinks you are already in game and are lagging massively. After several seconds of this lag it disconnects you, never giving you a chance to fully load the area.

Turning off addons should decrease your load time, as does turning down graphics. If neither of these work, you may have to get on a different computer to move your character and remember to never log off in that area. Or you could get a better processor/more RAM, but this isn't always an option.

Rated: +2 / -0

its Defenatly an Addon, Go through the List and disable them one by one untill you figure out which one it is and replace with with one that does a similar thing, or do without

Rated: +0 / -0

You might be disconnecting because your internet connection is crap, your computer can't handle it, or someone else is logging into your account.

Ether that, or there's issues with your account

Rated: +0 / -0

If the load screen takes a long time to pass it may be because you need more RAM. Thats what it was for me.

Rated: +0 / -1

You might be disconnecting depending on the area where your character was located like heavy traffic of peope in certain cities or places.

Or it's an addon. I know I had to turn off QuestHelper due to it kept DCing my main.

Rated: +0 / -0

If you are logging into Dalaran and you have Quest Helper installed (even if its disabled) you will encounter this problem a lot. Sometimes I have problems logging into Org as well, but deleting Quest Helper from my addons folder always does the trick.

Rated: +0 / -0

If another person is using your account, then you can't log in while they are on. I doubt that's happening thought. Perhaps y our connection is terrible and your main is in a high population area so your computer can't load it.

Rated: +0 / -0

Well, I've never had the questhelper bug. But i have had it where the patch had a bug and it didn't download my dranei (SP on that) chicks right, and it'd DC me everytime one would show up.
Maybe just try re-downloading the game with NO addons.

Rated: +0 / -0

Respond to this Question

You must be logged in to answer questions. Please use the login form at the top of this page.