Question from masterx88

Asked: 5 years ago

Can't access to World Editor?

I have the CD of it. I installed the patch 1.20c. It was all good even if you run the RoC or TFT. But I cannot access the World Editor. I have that worldedit.exe or whatever you call it. It always gets an error by saying that I inserted a wrong CD. What CD am I supposed to insert in to my CD-Rom? I inserted the TFT one but it doesn't work.

Additional details - 5 years ago

I tried clicking Battle Net but an error says:

Unable to validate game version.
Please reconnect to Battle.Net or apply the current game patch manually.

Additional details - 5 years ago

I have tried patching to the latest version (1.23) but this is what it says:

Blizzard PrePatch v2.70 compiled on Jul 7 2003
This program patches Warcraft 3

Log created at 2:50 pm on 06/13/2009

Registry error loading key 'Warcraft III\InstallPath'
The system cannot find the file specified.

RESULT: Prepatch failed

This question is open with pending answers, but none have been accepted yet

Submitted Answers

STATUS

Try to download the latest patch (just go to battle.net in your game), the patch 1.22b no longer requires cd to play

Rated: +1 / -1

You can uninstall the whole game and reinstall it, you do not have to go to the Blizzard website for updates(When you're on the game menu, simply click Battle.net and it updates everything automatically if your computer is connected to the internet). The World Editor should be working.
Extra Notes that might help you:
-If you have many custom maps, you may want to save them in another folder before uninstallation.
-Try the World Editor before you try connecting to Battle.net after uninstallation.
-Make sure you have no other programs on that may interfere with WcIII's performance.
-If you get this error again, manually go to the site and get the latest patch(some patches require steps before installation).

Rated: +1 / -1

This error sometimes occurs when changes are made to the folder Warcraft III is installed in. If, for example, you moved several files out of the directory and restored them later, or changed the folder name, some files may no longer be linked properly since the system registry still points to the old folder(s).

I suggest completely uninstalling and reinstalling the game, starting from Reign of Chaos. If Battle.net still sends you a message claiming your game version is invalid, register your CD key on the Blizzard website to make sure you have a legal copy.

Rated: +0 / -0

Maybe you should download the World Editor with the crack.

Rated: +0 / -0

You Pirated the game? If you have, try finding a crack on www.thepiratebay.org or something

Rated: +0 / -0

Respond to this Question

You must be logged in to answer questions. Please use the login form at the top of this page.