Question from dibbion

Asked: 1 year ago

I don't have the file folders in my minecraft.jar file. Why?

I'm trying to get a mod, but the question says it... Therefore I don't have a Meta.INF folder to delete to make the mods work. I don't know how to get the file folders back... I have 1.4.7, by the way... If anyone knows why I'm having these problems, please leave an answer... Thanks in advance...

Additional details - 1 year ago

I have both WinRAR and 7zip, but I tend to use the former. I know full well how to install mods. I follow the steps. When I'm told to open my minecraft jar file, I use WinRAR to open it. However, lately, I've had to open it to install mods, and I don't see the files up at the top like the accursed Meta.INF. If you can provide me with help, I would appreciate it. Oh, and the whole updating thing doesn't work. I tried it already.

Additional details - 1 year ago

I just tried force updating it, and, again, it didn't work. I have no clue, but on further inspection, I noticed some files that seemed as though they should actually be in folders.

Additional details - 1 year ago

And, uh... I get the mods installed properly, and I run minecraft, and all I get is a black screen. The META-INF isn't even there, so there's no way of deleting it to get the mods running properly.

This question is open with pending answers, but none have been accepted yet

Submitted Answers

STATUS

Do a force update to get a clean minecraft.jar if you want to start over from the beginning. Are you using an archiver like 7zip or winrar to open the minecraft.jar?

For an easier installation of mods I suggest getting MultiMC. MultiMC allows you to install the mods easier and still be able to play other mods if you'd like on different 'instances'. Each instance is like a different minecraft install.

MultiMC
forkk.net/MultiMC4/

Rated: +1 / -0

You can also get the 'pre-release' for 1.4.7 from mojang.com A pre-release is simply the minecraft.jar given so modders can make changes to their mods to make it work before it is released to the public. There are no changes to the minecraft.jar when it is released. This one I've checked has the META-INF
mojang.com/2012/12/minecraft-1-4-7-pre-release/

Just to check the folder is actually META-INF not META.INF just to be sure.
If this fails have you tried using the mods with the minecraft.jar you have without the META-INF?

Rated: +0 / -0

Respond to this Question

You must be logged in to answer questions. Please use the login form at the top of this page.