Question from Psychochria

Asked: 5 years ago

Anyone know how to fix a graphics issue with Age of Empires II: The Conquerors. Red grass/purple water?

I have been a long time Age of Empires II player, and have once suffered from the classic red grass and purple water graphics issue that a lot of people suffer from. However, using one of the below solutions, it eventually corrected itself. Recently, I installed Windows 7, build 7100 as my main operating system. AoEII (Conquerors exp. too) did not work on the original Windows 7 build, but now does, however, no matter what I do, scouring the internet for solutions and ways to solve the problem the graphics issue of the red grass and purple water stay. Here are the solutions I've read about and tried, all to no avail.

Changing the resolution
Alt tabbing
Opening a folder before the game loads
Unchecking "CPU 1" on the "Set Affinity" box in Task Manager
Updating graphics drivers to most recent
Updating DirectX to most recent
Running the game in compatibility mode for XP, Vista, 98, etc.

None of these solutions work at all, the green grass is still red, and the water is still purple.

Here are my system specs.

Windows 7 Ultimate 64-Bit Build 7100
AMD Athlon 64 6000+ ~3.0GHz
2GB RAM
NVIDIA GeForce 8800 GT
Direct X 11
Running at 1920x1080

Can anyone recommend any other solution to the graphics problem? Thanks.

Here's a picture of the issue (screenshotting doesn't show the graphics problem)

img4.imageshack.us/img4/6167/140520091107.jpg

Accepted Answer

From: Psychochria 5 years ago

Turns out all you need to do is alt-tab out of the game, and end explorer.exe from the task manager. This gives you flawless colours.

Rated: +0 / -0

This question has been successfully answered and closed

Submitted Answers

STATUS

An easier way is to adjust the screen size. (it worked for me)

Rated: +0 / -0

When I play in Vista, I get that error all the time. I just use ctrl + alt + delete to get to the task manager (faster than alt + tabbing). Sometimes I have to do it 6 or 7 times in a row before the problem is fixed.

See if that works for you. Like I said, you might have to do it a number of times until it is fixed.

Rated: +0 / -0

Ok, was looking for a solution for quite a while. This site has a neat guide about it:

blog.macuyiko.com/2009/07/solving-color-problem-red-grass-purple.html

It was the program that fixed things for me in the end, I never tried running AoC in a window. I just like my classics classically I guess. So good luck!

Rated: +0 / -0

Respond to this Question

You must be logged in to answer questions. Please use the login form at the top of this page.