Question from lgkaks

Asked: 4 years ago

4GB Installed (1.96GB usable) in Win7 x64?

I recently upgraded my RIG with the following specs:
CPU: Intel i5 760
Mobo: MSI H55-GD65
RAM: 2x2GB G.Skill DDR3 F3-2800CL9D-4GBRL
VC: Sapphire ATI Radeon 6870 1GB
PSU: Corsair TX750

My problem is that only 2GB (2007MB to be exact) is usable by Windows 7 Ultimate x64. In the properties of My Computer it says in the memory details

This question is open with pending answers, but none have been accepted yet

Submitted Answers

STATUS

Just making sure, the second stick of ram is in the right slot and pushed in properly? Cause some mobo's have the secondary ram slots (not 100% clear on them myself) Altho for it to have 2007 mb is odd

If that makes sense :)

Rated: +0 / -0

Dose your motherboard have any onboard graphics? If so make sure its disabled, and / or its not using up some ram for another reason

Rated: +0 / -0

You only have 1.96GB usable because the system reserves some amount of RAM (it changes per system) for usage. There are two potential things that are causing the problem:
1. One of your sticks has gone bad and isn't giving the full amount (but still giving some).
2. You have one of the sticks in the wrong slot/a slot has gone bad.
3. Your system has reserved an abnormally large amount.

For the first one, take out one of the sticks and see how much you have. If it's showing acceptable levels, check the other stick. If both are good, your sticks are fine. When putting both back in, make sure you're putting them in the right slots. If putting the second stick back in gives a small amount in comparison to how much it used to give in the first slot, the secondary slot has gone bad. If neither of those apply, then your issue is the third possibility. There really isn't a way to fix it besides reinstalling the OS.

Rated: +0 / -0

Are you sure your operating system is 64 bit because I had same problem I had 32 bit windows first and had put 6 gb ram but usable only 3 gb but when i upgraded to 64 bits i use all 6 gb ram so check that also plus open your pc and jus check once over the slots andremove and push it in again.

Rated: +0 / -0

I think Ellis123 is spot on here. The system reserves a portion of RAM, so it is not 'available'. At he minute I have 8GB Total RAM, 1.5GB In use, 6.5GB on standy and 0GB Free. Go to task manager->performance tab->resource monitor->memory tab and tell us your stats like I just gave. It would help alot.

Rated: +0 / -0

Respond to this Question

You must be logged in to answer questions. Please use the login form at the top of this page.