Stone Prisoner disappears from map, journal?

  1. This is for the DLC, Stone Prisoner. So I go to Sulcher's Pass, talk to the guy and he gives me the rod, telling me he'll mark the place on the map where the golem will be. After I leave dialogue I get a notification saying the entire quest is complete. Now its not in my journal, its not marked on my map, but I do still have the control rod. Can anyone help?

    My other DLC with the Warden's Keep works fine.

    User Info: Knives98

    Knives98 - 7 years ago
  2. Additional Details:
    Thanks Elwiwo, but I reinstalled it 3 times and it still isn't working for me

    User Info: Knives98

    Knives98 - 7 years ago

Accepted Answer

  1. I searched high and low through the Bioware forums and found my answer. I had to dl the DLC directly and replace them in my Documents/Bioware/Dragon Age folder. The links to download any of the DLC directly, not just the Stone Prisoner, are found in section 4.0 of this original post in Bioware forums:

    http:/social.bioware.com/forum/Dragon-Age/Dragon-Age-Origins-Technical-Support
    /Redeemed-DLC-Unofficial-Troubleshooting-and-FAQ-PC-Only-81613-1.html

    *Note: It won't let me post an actual link, so I had to remove a "/" from after http and split it up into two parts. Make sure and fix this before you try to use the link.

    User Info: Knives98

    Knives98 - 7 years ago 0 0

Other Answers

  1. He should of told you about a town to the south which has recently opened on your map. It is towards the SW corner of the map, I forget the name.

    User Info: mjb81

    mjb81 - 7 years ago 0 0
  2. This happend to me to. The place you should go is Village of Honnleath, but... you can't go because it doesn't appear in the map (I supose it's a bug). Like I said, it happend to me too, yesterday. I'll ask about it in the oficial forum in social.bioware.com and wait fot an answer...

    User Info: ElWiwo

    ElWiwo - 7 years ago 0 0
  3. I made it work. What I did was:

    - Deleted Manifest.xml in "C:\\Users\\\\Documents\\BioWare\\Dragon Age\\Settings"
    - Deleted (I made a backup, just in case) folder "dao_prc_cp_2" in "C:\\Users\\\\Documents\\BioWare\\Dragon Age\\AddIns"
    - Executed the launcher, selected the configure utility and in the repair option, I pressed the button "Clear Download Cache".

    After that, I ran the game in administrator mode, it downloaded again the Stone Prisoner DLC and... Honnleath appeared in the map in all my saved games.

    I had to try a couple of times until it worked. First time the game said to me that I had to buy Stone Prisoner. I restored the Manifest.xml and the dao_prc_cp_2 folder, started the game so it recogniced me it again... and start again all the process until it worked.

    User Info: ElWiwo

    ElWiwo - 7 years ago 0 0

This question has been successfully answered and closed.