Question from Ronarch

Asked: 5 years ago

Can I play the game with WinXP SP2?

I see from the box of the game , that the requirement for OS is winXP SP3

So... I just can't play the game with XP SP2 , can I?

Top Voted Answer

From: tyrionlan 5 years ago

You can play with sp2, I do.

Rated: +3 / -0

This question has been successfully answered and closed

Submitted Answers

STATUS

Apparently you can, however, I don't understand why you're holding out on downloading SP 3 for XP. It's actually a very worthwhile upgrade for your system.

Rated: +0 / -0

Respond to this Question

You must be logged in to answer questions. Please use the login form at the top of this page.