Question from Hedgie8520

Music doesn't play - why?

Whenever I start the game the music plays just fine. I go into the options menu then preview the songs, they work. When I go into the actual game itself and start playing, nothing 'musical' plays. The preview doesn't work, the buy mode/build mode music doesn't play (none of the songs), and the stereo doesn't play sound.

Uh I tried adjusting the directx sound levels and what not, it had no effect. Not sure what else I can do to get it to work. Bug? Patch? Setting I'm not getting?

Lswgamer asked for clarification:

That's a tough one. if the sound plays clearly outside of the game it may be a problem with your audio files, or you can go to options and try to see if there is something disabled. however if it doesn't play outside the game, then the source is the problem (i.e. headphones, the audio in your computer, volume etc...)

Andrewoffl asked for clarification:

Are these files .m4A or .m4P? These files are commonly from iTunes and will not run on the custom radio channels.

MedicD asked for clarification:

So, the music won't play, but all the other sounds work, right? Is this music the stuff from the game, or did you try to put your own music in the game? If you go into the music directory, can you play all the music files that are in there using windows media player?

Have you tried reinstalling?

wkw427 asked for clarification:

Exact same thing JUST happened to me, right now. Music worked in the main menu, load screen, then it didn't. It worked from the stereo, but not in build/buy mode, so I went to options to see what was wrong. When I went back it didn't work.

Top Voted Answer

wkw427 answered:

Found a fix.
You have to restore the backup file
2 0

Answers

fallenmistress answered:

I had the exact same thing happen to me. My laptop is running Vista and I have Realtek for the audio device. If you are running Vista I suggest that you go to the you audio device's website and see if there are any updates. For me, it turns out Realtek has a beta patch for Vista. Hope this helps.
0 0

trav523 answered:

This started happening to me after adding custom music. To get it to play again, I have to switch to a different station, then switch back to custom music.
2 0

Firemaster57 answered:

This just started happening to me recently. I haven't added any custom music to my game and I don't have vista so I'm not sure where the problem is coming from. Music doesn't play in Create a Sim eiter.
0 0

wkw427 answered:

Music does not play in live mode. You need to build a stereo system in your house if you want music to be on, and even then it depends on the sim's prefrences
0 1

jbdarjuan answered:

That's happens to my profile! this is spreading like mad but when start playing it make music next it had NO music!
0 0

docwat232 answered:

As said, in Live mode, music only plays from a stereo and the like. I have noticed music will not play in the build/buy modes if you put the game in the pause speed in live mode. Music does play if you switched to build/buy mode while time is running for your sims.
0 0

Raffeh answered:

This happens occaisionally for me. In Build/Buy modes, the music sometimes doesn't play. Just go back to live mode, wait a bit and then go back. it should play.

If not, check if the Music setting in the Options menu has been disabled.
0 0

nikey646 answered:

Lol, i like it with no sound, i ahte the sims 2 music and really just like hearing the sims act like sillys so my advice when ur sick or sad turn the music off by diaableing it, or not fix it...
0 0

This question has been successfully answered and closed


Ask a Question

To ask or answer questions, please sign in or register for free.