Why can't I download from the Sims 3 store?

  1. I checked out the store and was gonna use my points..clicked on some stuff to buy it, bought it and when the launcher came up I minimized it to let the downloads go, came back an hour later..they were all errored with 1kb downloaded..I've downloaded from the Exchange fine, no problems, but the store just won't work. I click on something and bam it's errored..all I get is a greyed out box and an error symbol in the status..for everything, I can't download Riverview..I can't download clothes, hairstyles..if it's store related, I can't get it..HELP?!

    User Info: manyfacesx88x

    manyfacesx88x - 7 years ago
  2. Clarification Request::
    Have you deleted the files and tried to download them again from your purchase history? Have you tried not minimizing the launcher to the tray during downloads? (as minimizing it always messes something up for me)

    User Info: SupeBigZeldaFan

    SupeBigZeldaFan - 7 years ago
  3. Additional Details:
    I have tried redownloading everything, minimizing the launcher was only the first time, haven't done it since. And when I say I've tried again I mean I cleared the launcher and tried again over and over until I got bored of trying.. Any way to download it as a file and bypass the launcher? I feel installing it through the launcher but not downloading it through the launcher may go over better.

    User Info: manyfacesx88x

    manyfacesx88x - 7 years ago
  4. Additional Details:
    I'm using the ten dollars worth they gave me with buying the game, and you have to sign up for an account with them to even get the Sim Points, so no that's not it at all.

    User Info: manyfacesx88x

    manyfacesx88x - 7 years ago
  5. Clarification Request::
    ok well this has been happening to me to and i was thinking maybe you have to update your game to be able to have new stuff downloaded. i'm not sure and i really don't want to update my game unless i HAVE to. so if any one wants to try good luck!

    User Info: tcaton6

    tcaton6 - 6 years ago
  6. Clarification Request::
    This is just a quick check off list for you to do:
    have you double clicked on download manager and activated your account?
    have you doubled clicked on download manager and activated your product code (not necesary but give it a try) ?
    Have you logged on to your sims acount so download manager knows who you are and what you're downloading?
    Try those things and if issues still persist, then email them.

    User Info: lolsforu121

    lolsforu121 - 6 years ago
  7. Clarification Request::
    AND make sure your updated completely

    User Info: lolsforu121

    lolsforu121 - 6 years ago

Top Voted Answer

  1. Make sure you have the latest update! happened to me multiple times, but i updated sims 3 and it was fine

    User Info: curkale1

    curkale1 - 6 years ago 2 0

Answers

  1. You either dont have any Sim Points, or you dont have an account on thesims3.com

    User Info: tubbsmcfat

    tubbsmcfat - 7 years ago 0 3
  2. I have this problem as well, it happens when i want to download something and when the TS3 lanucher pops up, all it does is to download 1kb and i'm unable to install anything because it doesn't download properly. what i do i simply log into EA download manager and try again a couple times. it has worked for me so far.

    User Info: LordKvartox

    LordKvartox - 7 years ago 0 0
  3. I just posted a question like 2 minutes ago about something similar. So I also need help with this.

    User Info: poweradefan100

    poweradefan100 (Expert) - 7 years ago 0 0
  4. Hey guys you need to use FireFox to download the objects. explorer doesnt work for some reason.

    User Info: SweetVibes118

    SweetVibes118 - 6 years ago 0 0
  5. i have the same problem!!! i have and am using Mozilla firefox, i minimized the thing, and nothing worked. i am getting tired of buying things with my simpoints that i got and not being able to download the things i bought! same goes for my sports car download and riverview.

    User Info: peacexlovexstp

    peacexlovexstp - 6 years ago 0 0
  6. Hey, I have been working on this for month, and been very rude to EA for wasting my time.
    However one sent me an automated response I had not seen. However i brushed it off because I thought I had tried everything.
    Weirdly. It worked. Please Please give this a try.

    (THIS IS NOT MY ADVICE, THIS WAS EA GAMES AND I HAVE NO CLAIMS TO IT)

    - Quit the game, if running and completely exit from the Sims 3 Launcher.
    - Open 'My Documents'. If you're using Windows Vista please refer to 'Documents' folder instead.
    - Double-click 'Electronic Arts'.
    - Right-click on The Sims 3 folder and choose 'Cut' from the pop-up menu.
    - Close the window. Right-click anywhere on the 'Desktop' and choose 'Paste'.
    - Now start the Sims 3 Launcher. You will need to re-download the items from the store.

    easims.custhelp.com/cgi-bin/easims.cfg/php/enduser/std_adp.php?p_faqid=21657

    User Info: rachellh08

    rachellh08 - 6 years ago 0 2
  7. I have the same problem!!!
    i used the sim points they gave me and downloaded them no problem but i had to restore my computer to factory settings an when i re installed the game i bought more sim points and bought more stuff and none of it will download not even the stuff i had previously downloaded!
    i dont know what else to do!

    i tried what rachellh08 suggested it didnt work either!

    User Info: morgs87

    morgs87 - 6 years ago 0 0
  8. I have bought alot of sims items from the store, they claim I purchased and downloaded them but they are not in my game, tryed everything everyone has suggested, nothing works and NO ONE! from EA to contact..I guess I quit buying from the store!! I can download exchange items and they show up, just not the things I've bought...a waste of my money.....

    User Info: bluedana

    bluedana - 6 years ago 0 0
  9. Im having the same problem, but for me it all downloads fine, says its installed in the game, and then when I go to play, it isnt there.
    I already installed some of it because my computer messed up, so im downloading it from purchase history, but theres a couple of things i just bought. Its really annoying :/ :/

    User Info: courtneeeym

    courtneeeym - 6 years ago 0 0
  10. Curkale1 Hopefully your right im updating everything in hopes i will be able to download my purchases to use them :) will keep all posted

    User Info: hellcat19

    hellcat19 - 6 years ago 0 0
  11. Curkale1 is right i just updated my sims because i couldn't download riverview but it really works to update sims.

    User Info: aottosson

    aottosson - 5 years ago 0 0

This question has been successfully answered and closed.