Will my MGS3 work?

  1. i have the first version of MGS3, will it work with MGS3:S? or do i need to start a new game, and also get the downlaod camos

    User Info: XgunsmokeX

    XgunsmokeX - 7 years ago

Accepted Answer

  1. No, save data is not compatible between versions, Snake Eater loads Snake Eater data, and Subsistence loads Subsistence data. At least I think that is correct.

    User Info: Kee715

    Kee715 - 7 years ago 2 0

This question has been successfully answered and closed.