Question from thatman75

How do I get past the last machine room?

I killed the last bad guy in the machine room but now I can't get to the other ledge in the room. How do I cross the chain and get to the other side?

Top Voted Answer

Jillarooney answered:

I've sussed it peeps!!! God how frustrating- all the solution is you press the inter-act button (Tri-angle) when she's on the chain keep tapping it pretty quick and off she skips!
Crazy ! The fast button is supposed to be L1, oh well got there in the end!
2 0

Answers

Kurokei answered:

I believe you are talking about the Antarctica stage that Thor's Palace is in.
If so, the room you are talking about must be the one with the non-moving gears, resulting in you not being able to get to the top of it. Dislodge the steel block that is blocking the gear's locomotion to the left of Lara when she first enter's the room.
1 1

Chicco-bre answered:

wn my version of the game i had/have serious problems here.
What you are supposed to do is grap the chain and hold the L1 button as your climbing across it to climb faster. - . My problem here (and possably yours too) is that the game does not let me speed climb so the chain just drags me into the wall behind (and thus i fall off and die. PS . i have tryed using other buttons to make her speed climb but she can't/won't do it)
anyway i found a glitch you have to get Lara standing up on the chain facing the oppisite end (use L1 to run along it a bit make sure your facing the front) position the camera directly behind her and she will pass through the wall behind her and come out at the other end of the chain (where on the chain varies from time to time so this may take a few trys and somtimes it dont happen and she falls off but it will work in the end . - . ive done it with success 4 times)
0 2

Jillarooney answered:

I have the exact same problem if yr talking about the same thing- and it looks like you are!
Its the last "hammer" to jump on to get out of this area by the looks of things, and the chain is going in the wrong direction. I'm gonna try what the guy above recomends it sounds like he knows eactly where we're stuck & I'll let you know!
He's hoping!
PP loving the game so far though..............
0 0

Jillarooney answered:

nope! tried Chicco-bre's answers and can't get it to work. This is driving me crazy! Pleeeaaassse someone, any one, help! In case my problems isn't clear;
Jan Maven Island - Valhalla
The last machine room - seems like all the rest except for the fact the chains you jump to are moving in the wrong direction. How do I get to the last hammer to get out of the area?
Is there a "speed climb secret? L1 doesn't do it. Can I somehow alter the gears so the chain alters direction, if so HOW? Please help before I lose my mind lol
0 0

GoddessLerraine answered:

HEY HEY HEY, I joined this site JUST to say thankyou to Jillarooney!! THANKYOU!! I have been stuck in this friggen room for like four months and tried everything, and that worked in a second! It was amazing! Now I have Thor's Hammer, and can finally continue the game! Thankyou sooo much!
0 0

shonae09 answered:

Im stuck at this part as well can anyone get past this?
0 0

Bstankem answered:

JIllarooney you are the man! like GoddesL I was stuck here for like 2 months, the stupid icon never appears for xbox 360 telling you to tap hit the yellow Y button once your on the chain, for speed climbing, there was never a time prior to this in the game we were taught or instructed about this skill/move ? EIDOS this was almost a dealer breaker for me.. thanks again
0 0

TND12 answered:

Thanks A LOOOOOOOOOOOOTTTTTTTTTTTTTTT Jillarooney
0 0

FoolsFolly answered:

Thankyou Jill!
0 0

torgyanom answered:

Jillarooney you are the greatest and what a debacle, action button indeed, ps I was playing on xbox 360 your advice worked for me too :)
0 0

This question has been successfully answered and closed

Answer this Question

You must be logged in to answer questions. Please use the login form at the top of this page.