What version of psp do we need to play this game?

  1. Just like the question
    Raiser356 - 5 years ago

Answers

  1. 6.20 is the firmware update on the disc.
    dancer62 - 7 months ago 0 0

This question was asked more than 60 days ago with no accepted answer.

Answer this Question

To ask or answer questions, please log in or register for free.

More Questions from This Game

Question Status From
What Ver. do I need to play this? Unresolved Rakenrol_08
Is this game a sequel to gundam assault survive ? Answered Archdin
Is there a english peacth? Unresolved AztecReaper6
What Ver. do I need to play this? Unresolved Rakenrol_08
What are the upgrades from top to bottom? Answered superidiotman

Ask a Question

To ask or answer questions, please log in or register for free.