Question from Raiser356

Asked: 3 years ago

What version of psp do we need to play this game?

Just like the question

This question is open with no answers submitted

Respond to this Question

You must be logged in to answer questions. Please use the login form at the top of this page.

Similar Questions

question status from
What Ver. do I need to play this? Unanswered Rakenrol_08
Is this game a sequel to gundam assault survive ? Answered Archdin
Is there a english peacth? Unanswered AztecReaper6
What Ver. do I need to play this? Unanswered Rakenrol_08
What are the upgrades from top to bottom? Open superidiotman