Question from Cyro1212kyenn

Asked: 4 years ago

What version of the psp is required for fat princess?

Please i need it alot!!!!!!!!!!!!!!!!!!

This question is open with pending answers, but none have been accepted yet

Submitted Answers

STATUS

So i can buy it

Rated: +1 / -0

If I recall correctly, it should be 6.20 or under.
I believe version 6.00 sounds quite right.

Rated: +0 / -0

Respond to this Question

You must be logged in to answer questions. Please use the login form at the top of this page.

Similar Questions

question status from
Is Fat Princess:Fistfull of Cake the same as Fat Princess for PS3? Answered mariobros210
Why cant i go online in infrastructure? Open csafu
Uh is there special classes? Answered UchihaOruben
How to unlock new Items? Answered No_Fun
Release? Answered kuzdydavid