Mic problems?

  1. I have a mic and it works on other games. When I go to options and headset. I speak and it shows it is registering. When I am in lobby where I see others with Mics it doesn't let me speak. It gives me the mute symbol. I mute all and unmute all and it still doesn't work. Any help?

    User Info: knifejuggling

    knifejuggling - 5 years ago

Top Voted Answer

  1. You need to add players as either a RIVAL or FRIEND before you can talk to them. The fact that you can see your MIC symbol though does suggest that you have a Rival or Friend present which is the only way that your MIC becomes active.

    You do need to have your MIC plugged in PRIOR to starting up multiplayer. Hope this helps

    User Info: Str8UpJack

    Str8UpJack - 5 years ago 2 0

Answers

  1. Happens to me too man :( i cant fix it!

    User Info: dswiftbr0

    dswiftbr0 - 5 years ago 0 0
  2. Can someone please tell high voltage these problems to them its really making me mad

    User Info: coyotzi

    coyotzi - 5 years ago 0 0
  3. You can't speak to random players unfortunately. It's like the original Conduit. I've read on a separate forum that High Voltage Software is using Nintendo's servers and that's why they aren't permitted to allow us to talk to strangers online. I can't confirm this with 100% certainty though. You may not have them on your Friends/Rivals list. That might be the problem.

    User Info: Babbo_The_Great

    Babbo_The_Great - 5 years ago 0 0

This question has been successfully answered and closed.


Ask a Question

To ask or answer questions, please log in or register for free.