Question from badham94

Asked: 3 years ago

Why can't I get the Bestiary Artefact?

Ok, so I'm 100% certain (I've checked the list 5 times) and I have every monster on my bestiary. But he still says it's short of his work.

I've tried everything and don't suggest I'm missing a monster because I'm not (100% sure).

I haven't got the check by every monster, but I was told this doesn't matter. Is this right?

Any people with a similar problem? It seems that my game is glitched.

Could the fact that I have Omega DLC and Lightning & Amador DLC cause the bestiary to muck up? I do have Omega, Lightning and Amador on my bestiary.

All help is appreciated.

Additional details - 3 years ago

Omg, thank you so much, I've never fought a Giant Cactuar before, if you've solved my problem I will love you forever! Just trying it now!

Accepted Answer

From: markisawsome 3 years ago

I had the same problem not too long ago, I swore I had every monster In the bestiary and I couldn't get the fragment either and I had just about gave up and I don't know if this is the answer your looking for but I believe you are missing a monster and I believe the one you are missing is Giant Cactuar NOT GIGANTUAR. If you go and fight a regular Cactuar and DONT kill it it will eventually use grow and transform into Giant Cactuar which is a whole new monster that goes into your bestiary when you defeat him. If you already have him then I don't know just go through your list again and if it still doesn't give it to you I guess your screwed. Hope this helpes

Rated: +0 / -0

This question has been successfully answered and closed

Submitted Answers

STATUS

If its not the giant Cactuar, been told that you need all the caius' from the paradox endings and proto fal'cie adams as well. I had all those done when I turned it in so not sure if that would effect it.

Rated: +0 / -0

Respond to this Question

You must be logged in to answer questions. Please use the login form at the top of this page.