Question from ann1224

Asked: 6 years ago

Archaeologist quest can't give her scroll?

Tried everything including gifting and starting over quest.

Additional details - 6 years ago

Well I finished the main quests and it started the archaeologist quest over again, but I still had the scroll and it still won't let me give it to her.Arrrggg!!

Additional details - 5 years ago

I finally beat the main storyline and still no luck.I have exactly what she asked for and still no go,oh well,was still a fun game,sure wish I could have gotton that quest done though.Guess I'll start over with a new character .

Top Voted Answer

From: SomethingSnake 5 years ago

Yeah same thing happened to me. I got the scro before going to the spire. When I got back, she wouldn't take it =( hopefully a patch will fix that

Rated: +2 / -0

This question has been successfully answered and closed

Submitted Answers

STATUS

Either
A. Wait for another patch to fix that
or
B.Just continue on doing other quests

Rated: +1 / -0

You may not be far enough in the game. Or something has happened with your file.
Stand around and wait for her o ask you, maybe?

Rated: +0 / -1

Maybe the quest isn't selected when you go to her......did you try that?

Rated: +0 / -0

Respond to this Question

You must be logged in to answer questions. Please use the login form at the top of this page.