Question from S0L1DSNAK3

Why does my game keep glitching?

Whenever I get t the Citadel, my game will always glitch, the first glitch happened when I tried to get in the door, the guy next to it said "Go ahead on in," but the door wouldn't open, Dr. Li was just pacing back and forth, after i restarted the game from the beginning, it happened again, this time though I was able to get in the door and all was well, but when itsad to talk to scribe Rothchild, he was gone, when I was in the courtyard, the marker was outside of the courtyard, i tried to leave but when I did it told me to go to some random place next to Springfield School. Of course nothing was there, so i decided to start over again, and the same thing happened at the same time, Rothchild was gone, someone please help because it is an amazing game and I would like to at least finish it.

Oh, and when I installed it to the HDD it has been freezing, it has never freezed before then.

SavemeJebus24 asked for clarification:

just to add, my game ISN'T installed onto my HDD, but im having the same problem with the second glitch that he is

S0L1DSNAK3 provided additional details:

I took it off my HDD and he still isn't there, I checked everywhere.

ali8283 asked for clarification:

It freezes for me all the time! I think its because I have a big save file of 12mg! It started to freeze when I got around 10mg!


Answers

Trenton357 answered:

Installing the game to the HDD may seem like a good idea, but several games, including Halo 3, and Fallout 3, have some issues when the game is being read from two sources. Fallout unfortunately has several small glitches, these glitches seem to occur in mass when the HDD is activated. I'd recomend deleting the HDD and just playing the game straight off the disk. This is of course, my own opinion, nothing professional.
0 0

richternj answered:

The game popped up a warning when I first had the option of installing it to my HDD. I'd recommend deleting it from your xbox and playing from the disc.

As to the second glitch, for some reason, even though the Map Marker points outside the courtyard, Rothchild seems to hang out in the lab/armory after you're told to talk to him.
0 0

Trenton357 answered:

Like I said, with HDD the glitches are much more common. They still occur without the HDD activated. As far as Rothchild not being where he's supposed to be...No clue, maybe it was a mistake in programing.
0 0

Florio131 answered:

The Xbox360 system sucks in general it has so many problems with it i have had 2 xbox360's fixed in the past month and one of them allready has sh*t the bed..... its sad that a nintendo from 1990 can last 20 years and work perfectly fine but an xbox360 that was made in 2010 only lasts a year if that...... PATHETIC!!!!!!!!!!!!!!!!!!!
0 0

This question is open with pending answers, but none have been accepted yet

Answer this Question

You must be logged in to answer questions. Please use the login form at the top of this page.


Ask a Question

To ask or answer questions, please sign in or register for free.