Massive lag on the build menu?

  • Topic Archived
You're browsing the GameFAQs Message Boards as a guest. Sign Up for free (or Log In if you already have an account) to be able to post messages, change how messages are displayed, and view media in posts.
  1. Boards
  2. Homeworld
  3. Massive lag on the build menu?

User Info: THeMUzikMaN

THeMUzikMaN
9 years ago#1
I'm amazed to see people still come here, awesome. I just reinstalled this game for the first time in three or four years, and am experiencing the classic problem of old games not running that well.

The entire game runs completely fine (although that trick for widescreen doesn't work for me, the cursor doesn't seem to adjust its width to a widescreen ratio), except the build menu. I get as massive drop in frame rate during it. All other menus are fine, but this one is killer. It's obviously not my system given how old the game is and I never had this problem with older systems. I thought maybe it was a problem with multicore processors (some old games have problems with them regarding timing, and I was surprised to see Homeworld utilizing all four cores), but even setting it to only run on one core didn't help. Any ideas? Have it patched up too.

Also, what's the current status of the master server? I appeared to connect to it earlier today, but it's down now. Does the official one still run or was I just getting a sort of fake connection earlier?
She says to you, "Nah, you're my knight who could slay nasty dragon barns."
Stratimus - Slaying your homes.

User Info: CPLHicks39

CPLHicks39
9 years ago#2

I recently got a similar itch for some homeworld goodness and had the same framerate problem in the build menu, although it also extended to the research and launch managers as well. Try switching the graphics API from D3D to OpenGL. If the game won't let you do that, enable compatibility mode for Win NT, and that should do the trick.

As for the master server, I've been wondering about that myself. Hopefully someone else can come by with an answer.

User Info: Marfoo

Marfoo
9 years ago#3
I've seen the massive slowdown as well, for me it was the result of enabling anti-aliasing on my graphics card, with it off it runs fulls speed.

User Info: THeMUzikMaN

THeMUzikMaN
9 years ago#4
The OpenGL suggestion worked, thanks. Kind of weird, perhaps a problem with the latest Direct X or modern implementations of it
She says to you, "Nah, you're my knight who could slay nasty dragon barns."
Stratimus - Slaying your homes.
  1. Boards
  2. Homeworld
  3. Massive lag on the build menu?

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived