"Preparing to Launch Team Fortress 2" Problem

  • Topic Archived
You're browsing the GameFAQs Message Boards as a guest. Sign Up for free (or Log In if you already have an account) to be able to post messages, change how messages are displayed, and view media in posts.
  1. Boards
  2. Team Fortress 2
  3. "Preparing to Launch Team Fortress 2" Problem

User Info: xSetax

5 years ago#1
Ok, so here's my problem: I was on my computer when I had the feeling of playing Team Fortress 2, so I click on the play button and it popped up a window that said "Preparing to Launch Team Fortress 2" this happens to everyone as it should normally for 10-20 seconds on my computer. It didn't launch it for a whole 5 minutes. I went to the bathroom and went to buy lunch and came back and the same window has been there for an hour.

So I went ahead and relogged onto my Steam account through the Change User button, but all that popped up was the window that warned you about logging off, I clicked "Restart Steam". It didn't do anything for 5 minutes and then a black small screen popped up with the loading sign on it not moving. I could drag it, but not close or click on anything on Steam. I alt-F4'ed out of it and tried to press the play button n Tf2, a huge black box appeared and I alt-F4'ed out of that and the other box came up from restarting steam, I did the same thing. By the way, I've tried to fix this all day but ultimately failed. How can I get Steam to launch Tf2 and fix all these problems with Steam?
That would be your mother!- Seta the Underrated Spy

User Info: foolm0ron

5 years ago#2
Reboot computer?
'Illegal activities is a slight misnomer, most of it is not related to material that is actually illegal.' - nintendogrl1

User Info: LRN_2_PLAY

5 years ago#3
This is happening to a lot of people atm. Try rebooting steam/your pc.
<gfaqs> because yes <gfaqs>
Format results: 1v1x(2x3x4x5x6x7/2/2570)

User Info: SuperJordan08

5 years ago#4
Just got this now too, came to ask actually..
i72600k | CFX6950's | P8Z68-V-Pro | 8GB GSkill | Eyefinity @ 6000x1080 | 6.1 S.S | Xpredator w/8 fans + TT Frio

User Info: drew872

5 years ago#5
also, getting this error. Can only assume gabe spent server money on pies again.

User Info: AxeInTheFace

5 years ago#6
Oh wow, I thought it was just me. It's happening for any game on Steam too.
If you lost your left arm, your right arm would be left.

User Info: Intro1827

5 years ago#7
That Steam update broke it
Smoky Progg is the best optional boss ever

User Info: wantfastcars

5 years ago#8
You guys know the file system where you put mods and maps for TF2? I can't speak of it specifically since I'm on a Mac, but in the folder where you "SteamApps" there should be a file called "ClientRegistry.blob". Close steam, wait for it to exit completely, then delete that file. I'm not sure what it does but it usually solves the problem of hanging on the "Preparing to launch..." window.
Currently Playing: TF2, Battlefield 3, Killing Floor, Vanquish

User Info: fig333

5 years ago#9
drew872 posted...
also, getting this error. Can only assume gabe spent server money on pies again.

Dude, everyone knows he gets pies and a can of coke
sent from my broken ipod touch with a broken unofficial Gfaqs app

User Info: RoyTheCoyBoy

5 years ago#10
I'm also having this problem with TF2 but every other game works fine.
Liverpool Football Club
You'll Never Walk Alone
  1. Boards
  2. Team Fortress 2
  3. "Preparing to Launch Team Fortress 2" Problem

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived