2nd White Phial quest problem (glitch?)

  • Topic Archived
You're browsing the GameFAQs Message Boards as a guest. Sign Up for free (or Log In if you already have an account) to be able to post messages, change how messages are displayed, and view media in posts.
  1. Boards
  2. The Elder Scrolls V: Skyrim
  3. 2nd White Phial quest problem (glitch?)

User Info: Corruption249

5 years ago#1
I did the first White Phial quest where you end up getting the cracked white phial. Eventually you get a letter that leads you to getting 3 ingredients to fix the phial. I have the unmelting snow and the crushed mammoth tusk.

My problem is with the Forsworn heart. I already have 2 of these from before I did this quest.However when I go to where the quest marker is, I've already cleared the area and all of the Forsworn there don't have heart's in them.

I tried to turn the quest in but the NPC won't take it. So what do I do? If I wait long enough will the Forsworn NPC respawn so I can kill him again? Or is my quest bugged?
Werewolf by Night 5 years ago#2
this happened to me also. i don't know of a fix, unfortunately.
the sky above the port was the color of television, tuned to a dead channel.

User Info: Blyr

5 years ago#3
drop the heart, and pick it back up

I already had all the ingredients 'cept for the mammoth powder, I just dropped them and picked them back up, quest updated.
Does it scare anybody else that the only metric Americans know, has to do with weapons? -Rampagingwalrus

User Info: Corruption249

5 years ago#4
Are you sure? I've tried dropping the Briar heart but it won't let me. It says something along the lines of "you cannot drop quest items". I'll go check again though to be sure.

Edit: Just checked. The briar heart is under ingredients while the other two are under misc. Is the briar heart not the quest item? It also won't let me drop it.

User Info: Corruption249

5 years ago#5

User Info: 8orcus8

5 years ago#6
I have the same issue. I even tried putting the briar heart back into the forsworn's body but it won't let me drop/store them. I've got about 12 of them in my inventory and I can't get rid of them.

I even bought a forsworn heart off the quest giver for this quest and it won't register as having acquired one. If you had one all along buddy......

User Info: Phainopepla

5 years ago#7
Try waiting a couple in-game weeks? Dungeon might reset itself at that point, so maybe the quest enemy will respawn.

And at the very least, if you have a spouse you'll get a couple thousand gold.

User Info: Corruption249

5 years ago#8
I went back to the spot. All of the Forsworn had respawned except for the Forsworn Briarheart (the quest npc).

I looked around on the web and it seems like the quest is bugged. People with the bug on the PC said that all they had to do was move the quest up to the next stage and they could complete it. Essentially, you have the item you are supposed to but the game isn't registering it. Maybe the upcoming patch will fix it.

User Info: thefinalzapkeet

5 years ago#9
let us hope
Go the Distance is the most inspirational song ever
those that agree: 30
  1. Boards
  2. The Elder Scrolls V: Skyrim
  3. 2nd White Phial quest problem (glitch?)

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived