Skyrim Quest Glitches(MISSABLE ITEMS)

  • Topic Archived
You're browsing the GameFAQs Message Boards as a guest. Sign Up for free (or Log In if you already have an account) to be able to post messages, change how messages are displayed, and view media in posts.
  1. Boards
  2. The Elder Scrolls V: Skyrim
  3. Skyrim Quest Glitches(MISSABLE ITEMS)

User Info: GMX

6 years ago#1
If you're like me, you want as many unique items as possible....

#1 & #2 most importantly, will *break every time* as far as I know -- and the other 2 will save you a google and some stress.

(Disclaimer that should be on the cover of every Bethesda game: Everyone should at least have 5-10 saves in any bethesda game) -- 3 autosaves arent nearly enough.
You want to be able to go back at least 10 hours of play, especially if you are a perfectionist / unique collector / insane / etc.

Accept the White phial quest line, from the alchemy shop named "The White Phial"(in Dawnstar) if you have a briarheart in your inventory.

It makes the quest uncashable, even if you find any amount of briarhearts after. Tried everything, and researched other peoples experiences. Currently unfixable. I think if you even take part 1 where briarheart isnt required, that it will still bug. "You cant eat a quest item"
Although the briarheart is only needed for part 2 of the quest, **that can only be acquired by courier letter, once you do part 1**.... it still would NOT let me drop the briarheart.

The white Phial is a refillable flask you can use once a day to buff yourself. Every 24 hrs game time which isnt long at all.... its awesome. Here is what you really want to know:

Taken from

+100 health)
. 20% magic resist for 60 seconds)
+20 stamina for 300 seconds)
+20 magicka for 300 seconds)
50% to one handed damage for 60 seconds)
20% harder to detect for 60 seconds)

The quest in Dawnstar to stop the nightmares. This one will break if the quest companion walks inside before you do.
It almost always glitches as Ive tested letting him walk in multiple times and he quantum leaps out of the galaxy.

What I did:
I killed the trolls in front of the tower. finished the conversation and ran in immediately. It worked.

**NOTE: You need him to open a door in the very 1st room.
Which is why if HE goes in first, he just teleports to the end and you cannot continue.**
He stops and wants to talk once more before entering so dont just run in.
Talk to him, and once he starts to walk, get in there before he does. Or reload...... This quest does give a (spoilers inc) unique staff or follower depending on your choice. Im a sucker for uniques.

Twilight Sepulcher:
The door wont open...... however if you use whirlwind sprint(forget name, acquired through storyline @ high hrothgar)
You can walk to the -right- side of the door.(only as far as I know) Youll notice the ground is missing and if you walk through you will fall and get stuck. Teleport over the gap with your shout, it works, and you CAN complete the quest. There is an alternate exit. Thankfully.

I only know of one more, however it isnt as serious as the last 3 - this wont get perma-stuck in your questlog

#4 This one involves the 3 pieces of the amulet quest "Forbidden Legends"
If you do the mage guild before you do the quest "FORBIDDEN LEGENDS", you will acquire a piece of the amulet. (1/3)
If you attempt to do the quest after, it wont register the 1st piece, nor give you quest credit.... so it seems.

But if you goto the temple where the quest begins, you can still complete it.
Quest involves leaving all 3 pieces on an alter to create ... (no spoilers)

The only glitch with this is that it doesnt show you where to go..... Its the tomb where the quest starts.

If this has been done, please bump his/her topic.!
It will save alot of people time!
Otherwise, bump this I guess... even if 1 person sees this I will have saved them 4 hours to my 15 writing this.

Hope this helped someone...... &

Happy hunting!
"One by one the penguins steal my sanity.."

User Info: GMX

6 years ago#2
"One by one the penguins steal my sanity.."

User Info: SSJ_MC

6 years ago#3
#2 didn't happen for me. I let him walk in before me and I had no problems. Lucky I guess.
Now Playing: TES V: Skyrim, Madden NFL 12, The Baconing
Gamertag: VillainousWolf

User Info: GMX

6 years ago#4
Damn this board moves fast!
"One by one the penguins steal my sanity.."
  1. Boards
  2. The Elder Scrolls V: Skyrim
  3. Skyrim Quest Glitches(MISSABLE ITEMS)

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived