This is how I've beaten the glitch. It works everytime.

  • Topic Archived
You're browsing the GameFAQs Message Boards as a guest. Sign Up for free (or Log In if you already have an account) to be able to post messages, change how messages are displayed, and view media in posts.
  1. Boards
  2. Pandora's Tower
  3. This is how I've beaten the glitch. It works everytime.

User Info: RPGNinja123

4 years ago#11
Natakiro posted...
Natakiro posted...
I found one that works every single time for me. I would have posted it sooner, but I have no internet access at home.

Anyway, what you do is pretty simple.

Once you get back from the Dusk/Dawn Towers to give Elena flesh, do everything you need to do first (store, buy, sell items; BE SURE TO GET RID OF YOUR FLESH! I only had it not work once and it was when I had flesh with me) and then save.

After you save, go back to the Wii Menu ( I accessed the menu by using the HOME Menu) and load the game again from there. Access your save on the game's main screen. Once it loads you back in the Observatory, immediately go to the place outside that lets you access the towers.
*BE SURE TO FOLLOW THIS AND TAKE YOUR TIME!! This might sound silly and tedious, but bear with me.

Once you are standing there, just stand there a few seconds (I count to seven seconds), then press the A Button to access the Tower List. Hover over the Dusk/Dawn Tower of your choice BUT DO NOT PRESS ANYTHING FOR 7 OR SO SECONDS! After ~7 seconds, press A to get the confirmation screen. WAIT AGAIN FOR ~7 SECONDS. After that, hit A and it should let you in.
*For the 7 seconds, I just had the light on the options go back and forth 7 times as my timer*

So, in short, anytime you need to go back to those towers:
1) get rid of all flesh and save
2) load the game again from the Wii Menu
3) stand outside the observatory in the Tower Select area and wait ~7 seconds then press A
4) Hover over the Dusk/Dawn Tower of your choice and wait ~7 seconds then press A
5) Hover over the enter tower option and wait ~7 seconds then press A
Yeah, takes about an extra minute of waiting to get in, but yeah.

I think the game apparently has a loading problem, because it worked for me every time if I had no flesh and waited 7~10 seconds before each option. I know this sounds convoluted and stupid, but it really worked for me.

Also! If you want to go back into these Towers after you complete them, register Centrum first by entering it and leaving, then do the above. It would not let me in until I registered Centrum.

Just to let you guys know, this isn't a joke. Might sound really dumb, but it worked for me over 50 times. I kept going back to upgrade all of my weapons and such. I tested a bunch of combinations (took forever), and only took it as a confirmation if it worked 5 times in a row. When I first got to these Towers, it would not even let me in, so I thought after a while, "Maybe it is just lame and needs time to load", so I decided to wait between confirming options, and it worked.

I really hope this works for you :D

I purposely keep a save right before the glitch because someone always feels like they found the "ultimate fix" for all situations. I did everything you described and it did not work.

So once again there isn't a fix for all situations.
[A Gamefaqs moderator was deleted by this message]
3DS FC- 0232-8140-1787(send PM if u add) RPGs are the best genre.
  1. Boards
  2. Pandora's Tower
  3. This is how I've beaten the glitch. It works everytime.

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived