Frozen game, corrupt data

  • Topic Archived
You're browsing the GameFAQs Message Boards as a guest. Sign Up for free (or Log In if you already have an account) to be able to post messages, change how messages are displayed, and view media in posts.
  1. Boards
  2. Worms Revolution
  3. Frozen game, corrupt data

User Info: djb12030

4 years ago#1
I just bought the game on XBLA and as soon as I choose a device to save on the game freezes the entire system. When I boot the system up and go to storage there is a corrupt game save file. This happens no matter which device I save to.

What can I do?

User Info: klateo

4 years ago#2
Same thing happened to me, except I've been playing it for the last few days and everything was fine, I was up to level 29 of 32 (hard work!), then the save became corrupt and all progress was lost.

Now the game won't start, every time it just creates a new corrupt save file and crashes.

Solutions I tried:

Creating the save on another storage device (memory card)

Using another xbox profile (in case it had a problem with mine)

Deleting entire game, redownloading...

Deleting xbox system cache

Nothing works, it just won't start now... It doesn't make any sense, since it was working fine yesterday and every day before that, and even a corrupt save shouldn't stop it from starting now after deleting everything and starting again.

User Info: chronotrig100

4 years ago#3
Bought it last night to play with some friends, and I tried pretty much everything that you tried...........
"Your future hinges upon this fight!"
100 cool points to whoever knows what game it's from.

User Info: greebe55

4 years ago#4
same thing here, really annoyed i hope my save games can be restored somehow with a patch

the problem seems to be everyone so your not alone

i have been reading the offical worms forum thread here

no response from team17 as of now

User Info: greebe55

4 years ago#5
chronotrig100 posted...
Bought it last night to play with some friends, and I tried pretty much everything that you tried...........

i just noticed thats you posting on team 17, lol i am guesing you have seen it already then

User Info: chronotrig100

4 years ago#6
yeah, i already posted so that they can hopefully fix it. I feel worse for the people whos games are getting corrupted after they spend time unlocking things. Hopefully they can fix it soon so i get my fix of worms.
"Your future hinges upon this fight!"
100 cool points to whoever knows what game it's from.

User Info: dhe18

4 years ago#7
Game is also broken for me. Will upon starting but goes directly to the tutorial and freezes there. Had no problems until I downloaded the most recent patch. This is absolute garbage.

User Info: ddmcgrath

4 years ago#8
I bought this game day one, beat Puzzle mode in a couple days, and was almost done with the campaign (which is painfully bad, I had to spread it out over a month).

Today I'm playing online with my friends, and when the game ends it crashed for all of us. Now we're all in this same boat.

Sounds like it's a fairly recent problem only?
I dont keep track of any official forums or anything. Whats the teams take on all of this?

This really sucks. We've been playing quite a bit, and if my achievement progress for things like kill 300 worms online reset too, I'm going to be pretty bummed.

Now that I think about it, the last couple weeks I tried to rename my worms, and I just now as I was typing this realized that it never actually saves their names...

I hadnt touched the campaign for the last couple weeks either, so it may have messed up long ago as well.

With as many Worms games as they keep releasing, you think they'd have a little bit better grasp on things by now. Another Worms title riddled with huge problems.

User Info: chronotrig100

4 years ago#9
Unfortunately guys, the only response we've gotten from the staff on this issue is that there is a workaround. When starting the game, choose no save device and basically continue without saving. You can then still play the game, but with no unlocks and no way to save the game (if you try re-enabling it, it just locks up again). Hopefully they find a way to fix this soon.
"Your future hinges upon this fight!"
100 cool points to whoever knows what game it's from.

User Info: klateo

4 years ago#10
I posted the following on the thread at the Team17 forum, but since I'm a new member there, my post is invisible while it's awaiting moderation.

I don't think Team17 can release a fix that will 'un-corrupt' the save files, the console definitely sees the file as corrupt and I don't believe that is fixable, but I could be wrong.

Anyway my save file is now gone, since I wanted to find the actual source of the problem and see if it's fixable - and I found a short-term solution.

This is good because now I can finally get the game running, although only for local play, so when my friends come over today we can play, using the trick that I'll describe later.

But first I want to explain how I figured out the problem.

I know it seems like the patch caused the problem - but I don't think that's the problem at all, based on my testing.

For example, I tried the following:

(1) Delete entire game from the console.

(2) Delete the corrupt game save.

(3) Go to the options for the hard drive, and delete the System Cache - this removes all patches (Title Updates) for all games on the hard drive.

(4) At this stage, there is NOTHING on your hard drive relating to Worms Revolution, it's as if it never existed. So now re-download the full game, but when you start the game do NOT let it download the patch. Now it STILL won't start, even though there is definitely no patch, it still creates a new corrupt save file!

So logically it seems the patch cannot be the problem. And since it seems that everybody started having this problem within the last 48 hours, it appears that a bug in the original (unpatched) game was lying dormant until this time and for some reason activated on a certain date.

And now it seems that I have proven my theory that the game breaks on a certain date, this is how you can test it (and get the game working again!)

(1) Disconnect your console from the internet (you need to do this to change the date on your console, otherwise it syncs to the correct date).

(2) Set your system date back to last month - don't worry about changing the day and year, just change the month back to 11.

(3) Delete your corrupt game save. (of course you'll lose all progress, but I believe there's no way of uncorrupting the file anyway)

(4) Start the game - it will work! So long as you stay off the internet so your date stays as last month, then it should continue to work.

Notice that this date-setting trick works even WITH the patch on the hard drive. In other words, the problem is not the patch, it's only the date.
  1. Boards
  2. Worms Revolution
  3. Frozen game, corrupt data

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived