Xbox Controller slightly messed up.

  • Topic Archived
You're browsing the GameFAQs Message Boards as a guest. Sign Up for free (or Log In if you already have an account) to be able to post messages, change how messages are displayed, and view media in posts.
  1. Boards
  2. Dark Souls: Prepare to Die Edition
  3. Xbox Controller slightly messed up.

User Info: nothing83

4 years ago#1
I have this problem (I think), when I play dark souls on the pc with my xbox controller, whenever my camera is facing forward and I try to move forward and to the left (diagonally) and forward and to the right, it makes me walk instead of run. I tried to search for a similar problem and couldn't find anything. Has this happened to anyone else or is this actually how it is? It makes running from and circling around monsters impossible.

User Info: Art Of Drowning

Art Of Drowning
4 years ago#2
This often happens with poor/erroneous calibrations. You can try to uninstall/reinstall the drivers, try fiddling with the config settings. Failing all that, you can do what I did. I tore apart my controller, ground away about a mm from the circle where the thumstick sits and now I can push this stick slightly further allowing me to run.

I'll give an example of what I suspect is happening:
Say you need to tilt, the stick to point 19 to start running. For whatever reason, your stick, on certain angles even at full tilt, is giving you 18.9. You can't run. Well, at 18.9 you can probably run occasionally (like I did) but if you can't run at all, you might be stuck lower, like 17. :\

I'm sure there is software that can over ride the default configs and allow you to adjust the zones yourself if you don't want to do the controller thing.
"A storm is brewing here right by my side
I've tried all sorts of disguises"
  1. Boards
  2. Dark Souls: Prepare to Die Edition
  3. Xbox Controller slightly messed up.

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived