Trying to fix Miraak glitch

  • Topic Archived
You're browsing the GameFAQs Message Boards as a guest. Sign Up for free (or Log In if you already have an account) to be able to post messages, change how messages are displayed, and view media in posts.

User Info: Codzilla00

4 years ago#1
Please bear with me, this is a little lengthy...

While fighting Miraak I encountered the glitch where my character absorbs the dragon soul instead of him. He can't heal himself, so he stays ethereal in the center of the arena. I tried reloading saves, damaging him slowly and killing all the dragons first, but nothing works.

I looked around to see if anyone has found a way around this, and some people have said that you need to let Miraak steal a dragon soul while you're playing before you actually fight him. I reloaded a previous save and found some dragons to fight. I would capture some of their souls, like what happens normally, but other dragons would die and just stay there, as if Miraak was supposed to come and steal them, but he doesn't come, so the dragon doesn't get its soul absorbed.

And btw, my brother was able to finish the fight without any problems, on the same console, but different account, but he didn't do as many side quests as I did, if that makes a difference.

If anyone knows a way to fix this I would greatly appreciate it. I really want to finish the dlc but I don't want to have to restart the whole thing.

User Info: Azrael0206

4 years ago#2
Not sure about this, but have you tried putting miraak between you and the dragon he attempts to absorb?
It seems whichever dragonborn is closest will absorb the soul for whatever reason.
So that might be whats happening?
Distance yourself when he uses the thuum to absorb, hope it works for ya.
Always willing to help!
Official Angel of Death

User Info: jaydan03

4 years ago#3
I seem to be having a completely different problem. Since I have met Miraak he is stealing all my dragon souls like he is supposed to but because of that I cant finish the quest. I don't have any souls saved to unlock the last part of the "Bend Will" shout so it wont let me continue with the quest and I cant just kill a dragon to get another one because he steals it from me. Advice?

User Info: casimirney

4 years ago#4
You don't have to let him steal any souls. I finished the quest without losing 1. My best advice is to slow down in battle, don't interrupt any dialogue, and stay back when he goes into his "absorb dragon phase." most issues with this battle are result from people bringing his health down too quickly with over powered attacks, or interrupting his sequence because they're impatient.

Also, he will not steal all dragon souls once he quest starts. Some people just seem to be unlucky. Just keep trying and be patient.

User Info: Souludus

4 years ago#5
I found a possible fix for the glitch involving Miraak, I believe I discovered the actual cause of the problem after some lengthy experiments. My first playthrough of the DLC was glitched like alot of others. Where Miraak does not absorbs the soul, therefore, gains no health and stays ethereal. I tried all methods known. Sneaking for him to regain health then reattacking him once hes out of the state. However, he repeats the same process of going Ethereal and attempts to absorb the soul of a Dragon that is already dead. I've tried punching. Doing small amounts of damage. Killing all the dragons first. Not killing the Dragons. But the result was all the same. Frustrating, I deleted the DLC and patch and redownloaded. After which, I reloaded a save prior to starting the DLC. I discovered that if the cultists discover you elsewhere, on the DLC island, rather than skyrim then for some reason, Miraak would not appear and absorb souls. In my reloaded save, after reinstalling the patch and DLC, and having progressed enough into the main questline prior, I was almost immediately approached by the cultists where as in the glitch with the absorbing all dragon souls, I traveled there by boat without meeting the cultists in the cities of Skyrim and instead met them on the island. On my second playthrough, having met them in the cities of Skyrim, Miraak appears as normal absorbing souls of Dragons. Thus, he was able to absorb souls in the final battle, though I kept from overdoing the damage just to keep it safe. I know its a pain but restarting the DLC after redownloading both it and the patch and meeting the cultists in skyrim and not turning the first dragon you kill after meeting Miraak to ash seemed to solve the problem, allowing a finishing of the DLC. I hope this helps.

User Info: JacobMarley

4 years ago#6
I appreciate the community effort to assist in fixing this bug but the bottom line is that there are indeed two separate glitches going on, and that fact should be understood before wasting any time trying to bypass the bug.

Firstly I'm really , really disappointed in Bethesda for not even acknowledging the bug/glitch in the Miraak boss battle on their support or community forums. That is the most basic form of customer / public relations. People spent good money on this game and then spent real-life hours only to reach what could be an insurmountable glitch without a Bethesda patch.

As many of the other threads around the web note, the worst of the two glitches occurs when you install the DLC before installing the most recent skyrim patch. The order of the installation actually matters. Installing the DLC and THEN patching the game with the most recent patch actually breaks those boss scripts. The clearest indicator of this was that you probably weren't able to find the boat after you first installed the DLC until you patched the game. Most likely you spent a while searching the docks and waiting to be visited by the cultists etc...Remember that? When this didn't happen that's when you most likely patched your game. If this scenario sounds familiar you WILL NOT BE ABLE TO KILL Miraak no matter what you do. Smaller weapons, killing/not killing dragons, invulning, insta-blinking him- none of this matters. What will happen repeatedly is that you will absorb the dragons souls instead of Miraak , causing him to keep invluning. I even tried to do the hide trick (if you hide long enough he'll exit his invlun stage) but it doesn't matter either- because he'll keep going back into invuln every time you attempt to kill him. He HAS to absorb the dragon souls or the boss battle cannot end.

The other scenario is that you DID install the patch before the DLC. In this case your glitch is less serious. You can just dicker around with highly nerfed attacks until he dies. It'll take longer , just watch how hard you hit him.

That's it. Basically scenario 1 folks are going to have to wait for a patch or alternately UNINSTALL the whole DLC and start from scratch from the beginning of the DLC. I'm not willing to do that. I'm hoping people will give Bethesda hell until they release a statement. And that's really all they'd have to do to help their customers out is give them an idea of when there will be a patch and let us know they're actually working on one. I'm really appalled that they haven't done this small thing... really- how hard is that?

Thanks again guys- love this community.

User Info: JacobMarley

4 years ago#7
I received an update from Bethesda Support today in regards to my query:

"We're definitely aware of the glitch, and we haven't denied the issue at all. The issue that you are experiencing is a known issue and we are working diligently to fix it in upcoming patches. Unfortunately at this time we do not have an ETA on when the next patch will be deployed. Aside from loading a previous save file prior to reaching that point in the quest and trying again (which we understand doesn't always work in the case of this particular bug), the best thing to do at this point would be to keep an eye on our forums, as this is the best source of information for emerging issues and patch information."

User Info: QR6MJ4

4 years ago#8
This is what worked for me. Good luck!

1.) Load up your save and collect any items you have stored on the island of Solstheim (if you do not, you will lose anything you have stored in a following step). Move anything you wish to keep (Dragonborn dlc items are the exception, those will disappear anyways in a moment) to Skyrim's mainland. Save your game in Skyrim and not Solstheim.

2.) Exit the game and clear the cache for your 360s hard drive and uninstall Dragonborn.

3.) Load Skyrim (without the Dragonborn dlc) and load up the save from step #1. The game will prompt you saying that content is now missing for this save and ask if you wish to continue, do it. When you load in any Dragonborn items will be gone, and your quest log will cleaned of anything having to do with the dlc. Save your game again (your save is now clean of anything having to do with Dragonborn but you still have any progress you made on your character in terms of working on skills and the like).

4.) Exit the game again and reinstall Dragonborn. Before you start the game again make sure that the title update is in place. When loading the game connected to Live it should prompt you if not, if so make sure to apply this. Also I read mention that some people saw that when looking under the System/Storage area of the 360 from the dashboard, there were multiple entries for the Skyrim game with the multiple entries saying title update. Not sure how that could happen but If this is the case, make sure those are deleted as when you start the game Live should apply the update properly if needed.

5.) Load your save back up and you should now be good to go. The Windhelm boat to Solstheim should be there, the cultist attacks awaiting, and everything on the island reset. You also should notice that, after meeting Miraak the first time and getting the boot from him, afterwards he can show up and steal a dragon soul after you down one. For me, it happened my first dragon kill on the island shortly after first meeting him. To be careful, I also did not explore the island at first and went straight forward with the main quest till I met him. After that I did nothing but hunt dragons down (not unlocking shouts, exploring, picking up quest, or anything). When he showed up he said a line or two as he magically ported in, stole the dragon soul, and then disappeared. If this happens, you can definitely rest assured in knowing he is not glitched anymore.

Back to top

User Info: ragnis

4 years ago#9
Hey all,

Just a quick question, to which I could find a definitive answer.
Will deleting Dragonborn DLC and clearing Xbox's cache and then reinstalling Dragonborn allow or not allow me to use my previous saves where the Miraak fight starts and will this not fix the glitch?
I was also the "Scenario 1 victim" (updating Skyrim only after installing DLC). So, theretically, deleting DLC and re-installing should reverse the process as the update will already be there after reinstalling DLC. Or am I missing something in by trail of thoughts?


User Info: ragnis

4 years ago#10
ragnis posted...
Hey all,

Just a quick question, to which I could NOT find a definitive answer.
Will deleting Dragonborn DLC and clearing Xbox's cache and then reinstalling Dragonborn allow or not allow me to use my previous saves where the Miraak fight starts and will this not fix the glitch?
I was also the "Scenario 1 victim" (updating Skyrim only after installing DLC). So, theretically, deleting DLC and re-installing should reverse the process as the update will already be there after reinstalling DLC. Or am I missing something in by trail of thoughts?


Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived