The message you selected is no longer available for viewing.

Game-Breaking Bug in Firefly Mission

  • Topic Archived
You're browsing the GameFAQs Message Boards as a guest. Sign Up for free (or Log In if you already have an account) to be able to post messages, change how messages are displayed, and view media in posts.
  1. Boards
  2. Batman: Arkham Origins
  3. Game-Breaking Bug in Firefly Mission

User Info: RaidenDP

4 years ago#1
I've encountered a game-breaking bug during the mission where Batman goes after Firefly on the bridge, and I believe it's worth warning people about, and possibly asking about a solution (though I'm 99% sure there isn't any). Thus far, I haven't seen this bug being reported anywhere, and the only way to "fix" it is to delete the save game and start anew, as far as I've tried. Also - spoilers.

The bug happens about 5 minutes after Batman speaks with Gordon on that mission. After doing some platforming through an elevator shaft, he enters a room full of goons, and makes a remark about interrogating one of them in order to reveal the location of the bombs Firefly has planted. Obviously, it is a Predator-type encounter, and it's also the first (and possibly only) room in the game where some gargoyles explode. If you die, you'll respawn about 2 minutes away from the room, which is kinda annoying, but certainly not game-breaking. The real problem for me was when I clicked "Restart". I was going for some Predator Dark Knight achievements (you know, "Don't get seen", "Beat a map without using Detective Mode"), that kind of stuff. When I was discovered, I decided to click Restart and try again. After the loading screen, Batman was spawned in mid-air way outside the map, with no way to return to it. After going through the water, he's just going to fall forever. Clicking "Restart" again causes the exact same thing to happen, as I suppose the game's checkpoint system saved over my working file with the glitchy one. Restarting the game and/or the system does absolutely nothing to repair the bug. I've tried flying around the map in an attempt to find some way to make my way in, but it is impossible. And since this is a story mission, fast travel has been disabled. The game is over, no matter what.

So, to anyone who has reached the room I described - DO NOT restart your checkpoint in there! Even if that's a glitch that just happened to me, do NOT take that risk! I suppose the only way for Warner Bros. Montreal to fix it is to release a patch that allows fast-travel during missions, as it appears that the glitch has already infected my save game.

User Info: BakuraGorn

4 years ago#2
There's also another gamebreaking bug in the room after this predator encounter where you have to lift an elevator with the shock gloves, but after charging it won't lift and you're stuck with no way to progress. I'm playing on pc but there's also some reports on consoles about this bug. Guess we'll just have to wait a patch from this developer, even though it should have already been out by now.

User Info: CyricsServant

4 years ago#3
Unfortunately, these types of game-breaking bugs are to be expected in auto-save only games. It wouldn't be such a big deal if you could actually create back-up save files.

User Info: diablogamer

4 years ago#4
Wow the list of bugs in this game just keeps growing and growing. I doubt we'll see a patch anytime soon as I'm sure they too busy grinding away to get out half baked season pass dlc.
"Reality is merely an illusion, albeit a very
persistent one" Albert Einstein

User Info: RaidenDP

4 years ago#5
I just discovered that if you fall down for long enough, eventually you'll land on an invisible ledge. Falling from that will result in death, and the standard animation of Firefly taunting you. This does not fix the glitch.

I also came up with a better solution for a future patch - a "Quit Mission/Return to Arkham" button. The ability to fast-travel during missions probably would have broken immersion, but I have no idea why there's no option to just cancel the mission altogether in case of a game-breaking bug.

User Info: RaidenDP

4 years ago#6
I apologize for the double post, but I believe I have just discovered a way to fix the glitch! I flew into one of the black spots on the left side of the stage (from where you are free-falling). The spot was kind of specific, but when I reached it, Batman pulled out his grappling hook and shot up, like he does when he falls in water. Next, he was shown climbing up on a ledge inside the stage. I'm not sure if this will work again if I try it, but it's worth a shot if it happens to you.

I still think a "Quit Mission" button would be a great idea, though.

User Info: zooknut

4 years ago#7
I haven't started playing this yet so youre saying there is only one save file for this game?

User Info: BakuraGorn

4 years ago#8
good to know you have solved the bug. I'm still stuck at the elevator though :( the game has 4 save slots, but there can be only 1 active at a time, it will just autosave on top of it.

User Info: Gunvalkyrie2

4 years ago#9
zooknut posted...
I haven't started playing this yet so youre saying there is only one save file for this game?

there are a few save files but you can only access them when starting a game. which ever file you pick the game will always autosave to it and you cant access an in-game save screen.

backing up with USB is a fix I'm surprised most people aren't using with such a rampant bug problem.

User Info: MorphineWell

4 years ago#10
I'm playing on the PS3 and I've experienced the glitch in which the elevator does not respond after charging up the generator. I'm basically stuck until its fixed. I've thought about just deleting my save and restarting, but I've got 8 hours in, Hopefully a patch is incoming...
  1. Boards
  2. Batman: Arkham Origins
  3. Game-Breaking Bug in Firefly Mission

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived