This is a split board - You can return to the Split List for other boards.

Castlevania Lords of Shadow demo problem

  • Topic Archived
You're browsing the GameFAQs Message Boards as a guest. Sign Up for free (or Log In if you already have an account) to be able to post messages, change how messages are displayed, and view media in posts.
  1. Boards
  2. PC
  3. Castlevania Lords of Shadow demo problem

User Info: sonicteam2k1

sonicteam2k1
4 years ago#1
I have a buddy who has the demo but when he loads the game it crashes. This happens when he gets to the mercury steam logo. Any ideas??? he has...

i7-3610QM
Geforce GTX 660M
8GB DDR3
Windows 7 64 bit
See The Game Collection
http://www.gamespot.com/users/nights_team2k7/games_table?mode=own

User Info: sonicteam2k1

sonicteam2k1
4 years ago#2
bump
See The Game Collection
http://www.gamespot.com/users/nights_team2k7/games_table?mode=own

User Info: Brainhunter

Brainhunter
4 years ago#3
He should check for any updated drivers (including Beta) from the official Nvidia website, for starters.
i5 2500K@4.5GHz|Gigabyte GTX660Ti Windforce OC|G.Skill Ripjaws DDR3 8GB|Samsung 840 Pro 256GB|Seagate Barracuda 7200RPM 3TB|Corsair TX750M|CM COSMOS

User Info: sonicteam2k1

sonicteam2k1
4 years ago#4
I'll let him know. I didn't even think about that
See The Game Collection
http://www.gamespot.com/users/nights_team2k7/games_table?mode=own
  1. Boards
  2. PC
  3. Castlevania Lords of Shadow demo problem

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived