This is a split board - You can return to the Split List for other boards.

HDMI sound issues, please help....

  • Topic Archived
You're browsing the GameFAQs Message Boards as a guest. Sign Up for free (or Log In if you already have an account) to be able to post messages, change how messages are displayed, and view media in posts.
  1. Boards
  2. PC
  3. HDMI sound issues, please help....

User Info: twiztidfreak6t9

twiztidfreak6t9
3 years ago#1
Okay, for some reason when I launch a game (Saints Row 4, SC:Blacklist, Dead Island Riptide, & a few others) it will display the game on my TV just fine via HDMI, but the sound will come out of the laptop speakers, instead of the TV.I've already got the HDMI sound set to default when it's plugged up.Also a few games like Blacklist being one, will play certain sounds from the laptop speakers (like when Grim is talking through the com), and the rest (gun fire, BG noise, etc...) will play through the TV....

All other audio I play such as music from itunes, movies, web based content, etc. play just fine......

What's up with this?
Alienware ALW14-1870SLV // Intel Core i7-4700MQ // 8 GB DDR3 RAM // 750GB 7200RPM Hard Drive // 1GB GDDR5 NVIDIA GeForce GT 750M

User Info: twiztidfreak6t9

twiztidfreak6t9
3 years ago#2
bump
Alienware ALW14-1870SLV // Intel Core i7-4700MQ // 8 GB DDR3 RAM // 750GB 7200RPM Hard Drive // 1GB GDDR5 NVIDIA GeForce GT 750M

User Info: twiztidfreak6t9

twiztidfreak6t9
3 years ago#3
No one can think of anything?BTW I do have the latest drivers too.
Alienware ALW14-1870SLV // Intel Core i7-4700MQ // 8 GB DDR3 RAM // 750GB 7200RPM Hard Drive // 1GB GDDR5 NVIDIA GeForce GT 750M

User Info: WerdnAndreW

WerdnAndreW
3 years ago#4
Try and disable your laptop speakers in the sound control panel.
Corsair 500r ~ P8Z68-V Pro ~ i5 2500k ~ Hyper 212+ ~ Corsair 2x4gb ~ TX750w v2 ~ 560 Ti ~ F3 1TB ~ Crucial M4 128GB ~ Xonar DG ~ Tt Meka G1 ~ Asus PA248Q

User Info: twiztidfreak6t9

twiztidfreak6t9
3 years ago#5
I messed up, Saints Row 4 & Deadpool work fine too.
Alienware ALW14-1870SLV // Intel Core i7-4700MQ // 8 GB DDR3 RAM // 750GB 7200RPM Hard Drive // 1GB GDDR5 NVIDIA GeForce GT 750M

User Info: twiztidfreak6t9

twiztidfreak6t9
3 years ago#6
WerdnAndreW posted...
Try and disable your laptop speakers in the sound control panel.


That worked!But is there no way around this? I may forget one time after a long gameplay session that I disabled it & think something else is wrong lol
Alienware ALW14-1870SLV // Intel Core i7-4700MQ // 8 GB DDR3 RAM // 750GB 7200RPM Hard Drive // 1GB GDDR5 NVIDIA GeForce GT 750M

User Info: Lonestar2000

Lonestar2000
3 years ago#7
Make sure your speakers are set to stereo.
Rumble Roses. Someone enters the room.
Them: O_O Me: What?! I always play games without my pants on!- Inmate 922335

User Info: AnatomyHorror

AnatomyHorror
3 years ago#8
twiztidfreak6t9 posted...
WerdnAndreW posted...
Try and disable your laptop speakers in the sound control panel.


That worked!But is there no way around this? I may forget one time after a long gameplay session that I disabled it & think something else is wrong lol


Don't be an idiot and you probably won't forget. This is a common thing to do when dealing with multiple audio devices. You have to change the device to the one you want. It really doesn't get any more simpler than that.

User Info: twiztidfreak6t9

twiztidfreak6t9
3 years ago#9
AnatomyHorror posted...
twiztidfreak6t9 posted...
WerdnAndreW posted...
Try and disable your laptop speakers in the sound control panel.


That worked!But is there no way around this? I may forget one time after a long gameplay session that I disabled it & think something else is wrong lol


Don't be an idiot and you probably won't forget. This is a common thing to do when dealing with multiple audio devices. You have to change the device to the one you want. It really doesn't get any more simpler than that.


It doesn't take an "idiot" to forget something, btw thanks for knowing how my brain works, I may be smart, but my memory is **** at times, and thats not something I can't help.I can literally forget something I was going to say or do at times within seconds of thinking it.Thanks for diminishing myself as a human being ;)

A simple "nope there's unfortunately no way around this" would have sufficed......
Alienware ALW14-1870SLV // Intel Core i7-4700MQ // 8 GB DDR3 RAM // 750GB 7200RPM Hard Drive // 1GB GDDR5 NVIDIA GeForce GT 750M

User Info: Saber_Dark

Saber_Dark
3 years ago#10
My laptop does the same thing, it's quite annoying. Unfortunately there isn't a way around it. You need to do it every time you hook in the HDMI (unless you just leave the laptop hooked in, then it should save it).
  1. Boards
  2. PC
  3. HDMI sound issues, please help....

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived