This is a split board - You can return to the Split List for other boards.

Help I cant get into my bios anymore

  • Topic Archived
You're browsing the GameFAQs Message Boards as a guest. Sign Up for free (or Log In if you already have an account) to be able to post messages, change how messages are displayed, and view media in posts.
  1. Boards
  2. PC
  3. Help I cant get into my bios anymore

User Info: Oxn518

Oxn518
3 years ago#1
So I got a Z77 Asrock Pro 4, and for some reason I can no longer get into my bios.

I smash that F2 and/or delete button and it skips it anyways. My KB is plugged into the mobo directly.

What can I do?
i5 3570k | XFX 6870 | 8gig DDR3 ram

User Info: Th1rte3n

Th1rte3n
3 years ago#2
Have you tried reseting the bios?
i7-920 @ 3.6 // 770 GTX // 12 GB G.Skill Sniper Ram // PS3 // 360
FiiO e9+17 // AD700 + M50 // Deck Legend + 82 // DAS Ultimate S

User Info: CriticalFury

CriticalFury
3 years ago#3
I had this same problem before. Try plugging your keyboard in a different usb before turning the pc on. In my case I used the usb from the back of my computer and then it worked.
"They say I can't lose, I say you can't win."- Mike Tyson's Punch-Out!!
  1. Boards
  2. PC
  3. Help I cant get into my bios anymore

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived