This is a split board - You can return to the Split List for other boards.

Some of my Steam games won't start?

  • Topic Archived
You're browsing the GameFAQs Message Boards as a guest. Sign Up for free (or Log In if you already have an account) to be able to post messages, change how messages are displayed, and view media in posts.
  1. Boards
  2. PC
  3. Some of my Steam games won't start?

User Info: DeathScythe_527

DeathScythe_527
3 years ago#1
Whenever I try to launch Mass Effect or Assassin's Creed 3, literally nothing happens. The blue circle spins by my mouse for a few seconds, and then just goes away. There aren't any changes in task manager, like the game actually starting or anything. I tried verifying cache, but that didn't do anything. Anyone have an idea on how to get the games running? I could play them before fine, but for some reason now I can't.
PSN: DANomite93
"El delfin esta en el jacuzzi."

User Info: Pokenub

Pokenub
3 years ago#2
Restart your pc.
Damn it.. I swear I had something for this..

User Info: DeathScythe_527

DeathScythe_527
3 years ago#3
Tried that, same thing still happens.
PSN: DANomite93
"El delfin esta en el jacuzzi."

User Info: Cowboy082288

Cowboy082288
3 years ago#4
Were there any changes that you made between when you could play them and then could not play them? Or any updates ect.?
PSN/XBL/Steam/iOS - cowboyoni

User Info: Cool_Dude667

Cool_Dude667
3 years ago#5
hit ctrl+shift+esc and go to processes, sometimes a games launcher or client will bug out and the application won't show up, but ending the process tree should fix it
Not changing this sig until Christ returns -- Started 30 A.D
3770K @ 4.2Ghz | 16GB Corsair Vengeance | GTX 670 SLi

User Info: pitt12177

pitt12177
3 years ago#6
Uninstall and reinstall. Only way to fix it.

User Info: DeathScythe_527

DeathScythe_527
3 years ago#7
The only changes I can think of are going from HD 6870 to R9 270x and 4gb > 8gb ram. Most of my other games run fine, those are the only two I've checked that don't run.
PSN: DANomite93
"El delfin esta en el jacuzzi."

User Info: DeathScythe_527

DeathScythe_527
3 years ago#8
Cool_Dude667 posted...
hit ctrl+shift+esc and go to processes, sometimes a games launcher or client will bug out and the application won't show up, but ending the process tree should fix it


Yea the process starts for a few seconds, and then goes away by itself.
PSN: DANomite93
"El delfin esta en el jacuzzi."

User Info: DeathScythe_527

DeathScythe_527
3 years ago#9
Ok well I started AC3 again, and it asked me to install the redistributable. After that it updated uplay and let me play the game. Is there any way to force a reinstall of the redistributable for ME also?
PSN: DANomite93
"El delfin esta en el jacuzzi."

User Info: Cowboy082288

Cowboy082288
3 years ago#10
Kinda hard to diagnose this from a forum but you did change video cards. I actually have the same video card as you and can run AC 3, I don't have the other game.

Maybe check the drivers. Go to the AMD site and get their video card software sweet if you haven't already. Make sure that your new Video card is registering.

Other then that all I can say is like the other person, uninstall and reinstall. Hard to say without actually being there.
PSN/XBL/Steam/iOS - cowboyoni
  1. Boards
  2. PC
  3. Some of my Steam games won't start?

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived