This is a split board - You can return to the Split List for other boards.

cant get thief to run properly

  • Topic Archived
You're browsing the GameFAQs Message Boards as a guest. Sign Up for free (or Log In if you already have an account) to be able to post messages, change how messages are displayed, and view media in posts.
  1. Boards
  2. PC
  3. cant get thief to run properly

User Info: Skunkdog1

Skunkdog1
3 years ago#1
even at the lowest settings it still barely gets higher than 30 FPS
ive tried all the fixes i can find to get it to run properly, and nothing works
anyone have any suggestions?

running a gtx 780 btw
BY FIRE BE PURGED
http://i.imgur.com/51ydFkh.png

User Info: kickthegnome

kickthegnome
3 years ago#2
Turn ssaa to low or off

Also turn off "contact hardening shadows" and "screen-space reflections" Not many textures use the ssr option so and the ones that do are mostly puddles. You could look at a puddle and it's using ssr but the puddle next to it isn't. but it eats up a ton of performance.

User Info: kickthegnome

kickthegnome
3 years ago#3
You can also try this

Modifying Texture Memory Pool Size:

This a tweak that usually improves framerate smoothness with all Unreal Engine 3 games. You need to change the "PoolSize" value in the game's engine.ini file to [your GPU's VRAM amount in GB] x 600. This translates to the following values:

1 GB => PoolSize = 600
2 GB => PoolSize = 1200
3 GB => PoolSize = 1800

... and so on!

1. Navigate to your ...\ThiefGame\Config folder
2. Backup your ThiefEngine.ini file
3. Open the ThiefEngine.ini file with a text editor
4. Change

"PoolSize=0"

to

"PoolSize=[the value appropriate for your GPU, calculated as shown above!]"

5. Save the file and set it to "read-only".

6. Go to your Steam library, right-click on Thief > Properties > Set Launch Options > Type in "-ReadTexturePoolFromIni" > OK (apparently this step is optional; thank you for reporting back, CiroConstantino!).

That's it, you're good to go!

V. Disable framerate smoothing

THIEF natively supports high frame- and refresh rates when "Exlusive Fullscreen" is turned ON. However, the "Borderless Windowed" mode (i.e. "Exclusive Fullscreen" turned OFF) employs framerate smoothing within the values of 22 and 62, effectively capping your overall FPS. Disabling framerate smoothing as following will remove this cap and unlock the extra performance:

1. Navigate to your ...\ThiefGame\Config folder
2. Backup your ThiefEngine.ini file
3. Open the ThiefEngine.ini file with a text editor
4. Change

"bSmoothFrameRate=TRUE"
"MinSmoothedFrameRate=22"
"MaxSmoothedFrameRate=62"

to

"bSmoothFrameRate=FALSE"
"MinSmoothedFrameRate=0"
"MaxSmoothedFrameRate=0"

(For "MinSmoothedFrameRate" and "MaxSmoothedFrameRate" you can write any values you want, they won't be taken into consideration if "bSmoothFrameRate" is set to FALSE!)

5. Save the file and set it to "read-only".

I'm running off a 560 and after doing all that, turning motion blur off, etc. I can run the game at 30-50 fps as opposed to 20 and everything else is set to high.

User Info: kickthegnome

kickthegnome
3 years ago#4
Triple post but:

Thief on the pc is poorly optimized. It's not so much of hardware thing as it is that the game itself just wants to eat performance. But those tweaks should help.

User Info: reincarnator07

reincarnator07
3 years ago#5
What's the rest of your rig like?
Fan of metal? Don't mind covers? Check out my youtube and give me some feedback
http://www.youtube.com/sircaballero

User Info: protools1983

protools1983
3 years ago#6
Who cares? The game is a turd.
Xbox One - The console that made me the PC gamer I am today.
Yah like dahgs?

User Info: Raikouen

Raikouen
3 years ago#7
protools1983 posted...
Who cares? The game is awesome.
Why walk when you can ride? Same low price ;)

User Info: Cosmic_Coyote

Cosmic_Coyote
3 years ago#8
If the Thief can´t run properly he isn´t good for the job
"There is no knowledge that is not power"

User Info: SinisterSlay

SinisterSlay
3 years ago#9
Cosmic_Coyote posted...
If the Thief can´t run properly he isn´t good for the job


Win
He who stumbles around in darkness with a stick is blind. But he who... sticks out in darkness... is... fluorescent! - Brother Silence

User Info: Killah Priest

Killah Priest
3 years ago#10
I dunno my R9 290x obliterated it on max settings using mantle.
Laugh, and the world laughs with you. Weep, and you weep alone.
The armory of god is guarding me but all you can see is holographic artistry.
  1. Boards
  2. PC
  3. cant get thief to run properly

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived