This is a split board - You can return to the Split List for other boards.

Do you think FF15 will actually require windows 10 to run?

  • Topic Archived
You're browsing the GameFAQs Message Boards as a guest. Sign Up for free (or Log In if you already have an account) to be able to post messages, change how messages are displayed, and view media in posts.
This topic contains spoilers - you can click, tap, or highlight to reveal them
  1. Boards
  2. PC
  3. Do you think FF15 will actually require windows 10 to run?

User Info: nominturddaddy

nominturddaddy
3 weeks ago#11
They should offer two versions:

- A 170gb version for those of us who like uncompressed games (but if it has multi-language bloat dump that s***)

- A compressed turd for everyone else.
My current setup: https://i.imgur.com/c8xbRW0.png
Some of my gamer cred: https://i.imgur.com/RVpcz3Z.png

User Info: captsplatter_1

captsplatter_1
3 weeks ago#12
NecroAether posted...
Just gonna post the REAL requirements! The day the game was announced fake requirements were posted. These are the real requirements. Keep in mind these were taken from the Windows 10 App Store. A Steam version is also coming that supports DX11.
http://www.game-debate.com/news/23964/final-fantasy-xv-system-requirements-arent-as-demanding-as-previously-claimed

Final Fantasy XV Minimum System Requirements

OS: Windows 10 64-bit
CPU: Intel Core i5-2400 3.1 GHz or AMD FX-6100 3.3GHz
RAM: 8 GB System Memory
GPU RAM: 2GB Video Memory
GPU: GeForce GTX 760 or Radeon R9 280
HDD: TBC (170GB Originally Announced)
DX: DirectX 12

Final Fantasy XV Recommended System Requirements
OS: Windows 10 64-bit
CPU: Intel Core i7-3770 3.1 GHz or AMD FX-8350 4.0GHz
RAM: 16 GB System Memory
GPU RAM: 6GB Video Memory
GPU: GeForce GTX GeForce GTX 1060 6GB or Radeon RX 580
HDD: TBC (170GB Originally Announced)
DX: DirectX 12

Ya they updated because before you needed a 1080 Ti gpu cause of the 4k.
PSN: captsplatter & Gamertag: OGcaptsplatter &
Switch FC: SW-3078-9578-8685 & Steam ID URL: http://steamcommunity.com/id/captsplatter NO BLANK REQ.

User Info: NecroAether

NecroAether
3 weeks ago#13
captsplatter_1 posted...
NecroAether posted...
Just gonna post the REAL requirements! The day the game was announced fake requirements were posted. These are the real requirements. Keep in mind these were taken from the Windows 10 App Store. A Steam version is also coming that supports DX11.
http://www.game-debate.com/news/23964/final-fantasy-xv-system-requirements-arent-as-demanding-as-previously-claimed

Final Fantasy XV Minimum System Requirements

OS: Windows 10 64-bit
CPU: Intel Core i5-2400 3.1 GHz or AMD FX-6100 3.3GHz
RAM: 8 GB System Memory
GPU RAM: 2GB Video Memory
GPU: GeForce GTX 760 or Radeon R9 280
HDD: TBC (170GB Originally Announced)
DX: DirectX 12

Final Fantasy XV Recommended System Requirements
OS: Windows 10 64-bit
CPU: Intel Core i7-3770 3.1 GHz or AMD FX-8350 4.0GHz
RAM: 16 GB System Memory
GPU RAM: 6GB Video Memory
GPU: GeForce GTX GeForce GTX 1060 6GB or Radeon RX 580
HDD: TBC (170GB Originally Announced)
DX: DirectX 12

Ya they updated because before you needed a 1080 Ti gpu cause of the 4k.


The director came out actually and stated that the specs that were released first were not real. THAT is the reason why.
https://www.tweaktown.com/news/58876/final-fantasy-xv-pc-specs-erroneous/index.html
No conflict can ever be resolved by causing pain to another human being. - Madonna

User Info: Chaos_Missile

Chaos_Missile
3 weeks ago#14
yohabroha posted...
Chaos_Missile posted...
FFXV runs on PS4 and not Xbone
AFAIU, PS4 is NOT using an architecture like Windows the way Xbone is.

Therefore, FFXV requiring Win10 to run is as truthful as Microsoft telling us that Vista was required to run Halo 2.

uhhh FFXV is on Xbox One


I...actually did not know that(thought it was PS4 exclusive. Seriously, why do developers keep wasting money porting RPGs to a console primarily known for pewpew Western games?)

My point still stands.
Action speaks louder than words. But words, when used right, overwhelm any action - Me, 2006
Let's put a smile on that face - The Joker, 2008

User Info: Samurai_Man

Samurai_Man
3 weeks ago#15
NecroAether posted...
Just gonna post the REAL requirements! The day the game was announced fake requirements were posted. These are the real requirements. Keep in mind these were taken from the Windows 10 App Store. A Steam version is also coming that supports DX11.
http://www.game-debate.com/news/23964/final-fantasy-xv-system-requirements-arent-as-demanding-as-previously-claimed

Final Fantasy XV Minimum System Requirements

OS: Windows 10 64-bit
CPU: Intel Core i5-2400 3.1 GHz or AMD FX-6100 3.3GHz
RAM: 8 GB System Memory
GPU RAM: 2GB Video Memory
GPU: GeForce GTX 760 or Radeon R9 280
HDD: TBC (170GB Originally Announced)
DX: DirectX 12

Final Fantasy XV Recommended System Requirements
OS: Windows 10 64-bit
CPU: Intel Core i7-3770 3.1 GHz or AMD FX-8350 4.0GHz
RAM: 16 GB System Memory
GPU RAM: 6GB Video Memory
GPU: GeForce GTX GeForce GTX 1060 6GB or Radeon RX 580
HDD: TBC (170GB Originally Announced)
DX: DirectX 12


This makes so much more sense.... I showed this too my roomate and he literally flipped s*** because he's never seen a game recommend 11GB of VRAM
It's your friendly neighborhood Samurai Man.

User Info: Samurai_Man

Samurai_Man
3 weeks ago#16
Chaos_Missile posted...
FFXV runs on PS4 and not Xbone
AFAIU, PS4 is NOT using an architecture like Windows the way Xbone is.

Therefore, FFXV requiring Win10 to run is as truthful as Microsoft telling us that Vista was required to run Halo 2.


Please elaborate on that first statement, XV runs fine on my Xbox One
It's your friendly neighborhood Samurai Man.

User Info: BearShrooms

BearShrooms
3 weeks ago#17
So the minimum system requirements are higher than the original system the game released on? I smell a s***ty port incoming.
#18
(message deleted)

User Info: Samurai_Man

Samurai_Man
3 weeks ago#19
Chaos_Missile posted...
yohabroha posted...
Chaos_Missile posted...
FFXV runs on PS4 and not Xbone
AFAIU, PS4 is NOT using an architecture like Windows the way Xbone is.

Therefore, FFXV requiring Win10 to run is as truthful as Microsoft telling us that Vista was required to run Halo 2.

uhhh FFXV is on Xbox One


I...actually did not know that(thought it was PS4 exclusive. Seriously, why do developers keep wasting money porting RPGs to a console primarily known for pewpew Western games?)

My point still stands.


Oh nvm... Obvious troll is obvious
It's your friendly neighborhood Samurai Man.

User Info: darkus_f

darkus_f
3 weeks ago#20
Apex_Predator posted...
170 GB.... holy s***

This is my main concern actually. :/
For by grace are ye saved through faith; and that not of yourselves: it is the gift of God
  1. Boards
  2. PC
  3. Do you think FF15 will actually require windows 10 to run?

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived