This is a split board - You can return to the Split List for other boards.

How to stop windows 10 from updating nVidia Drivers?

  • Topic Archived
You're browsing the GameFAQs Message Boards as a guest. Sign Up for free (or Log In if you already have an account) to be able to post messages, change how messages are displayed, and view media in posts.
  1. Boards
  2. PC
  3. How to stop windows 10 from updating nVidia Drivers?

User Info: Lilrosco

Lilrosco
4 weeks ago#1
There was another topic related to this but no one mentioned a way to prevent this from happening. I had my nVidia driver 385.69 and didn't want to update since someone on the nVidia forums pointed out frametime spikes when using a GSync monitor on drivers past the version I mentioned. Sadly Windows 10 keeps forcing the update 388.13 on me and with it the other stuff I don't need. I've tried setting device installation settings to no but that didn't work. Any ideas to just prevent this particular driver from updating?

Many thanks!
There is no better way to defeat your enemies but to slice and dice em right Link?...oopz forgot you can't speak. Well I guess a simple head nod is sufficed.

User Info: fsunolez75

fsunolez75
4 weeks ago#2
I know my post is the antithesis of helpful, but i didnt know win10 could auto update nvidia. I usually have to hunt down the nvidia xperience .exe on my c:\ drive (or whatever their program is called) whenever i want to update my driver.
Money saving tip: Since it costs 2 cents to share your thoughts, and you only get a penny for them, just stop talking.

User Info: Lilrosco

Lilrosco
4 weeks ago#3
Yea I noticed this before, Windows updating my drivers even though I had one installed. Like the only way you would notice is your screen flashing while you are using it and the sound effect of something disconnecting and connecting. I recall I was playing PREY and there were moments I was having performance issues. Found out Windows installed a different driver version that what I originally had and wouldn't let me keep the older version. I ended up manually updating my drivers after using DDU and the spots where my frame rate would tank were fine again.
There is no better way to defeat your enemies but to slice and dice em right Link?...oopz forgot you can't speak. Well I guess a simple head nod is sufficed.

User Info: Pineapple5

Pineapple5
4 weeks ago#4
There's a setting buried somewhere. Google it (or did you want someone else to do it for you?).

User Info: jhood

jhood
4 weeks ago#5
are you on a wireless connection? if so you can set it to a metered connection and
windows wont update until you tell it too. you can also disable windows updates in services.
6700k @4.6ghz | Corsair H105 | Gigbayte Z170 HDP3 | 32gb Corsair Vengeance LPX 3000mhz | MSI GTX 1080 Gaming Z | Evga 1000w G2 |

User Info: Lilrosco

Lilrosco
4 weeks ago#6
So I might have stumbled on to something. Not sure if it really worked but here goes nothing

https://goo.gl/ZeKWij

Following the info from that link (nVidia GeForce forum post), I

1) Booted into Safe Mode
2) Used DDU to remove the nVidia driver installed
3) Unplugged my machine from internet
4) Restarted Windows
5) Installed the driver of my choice
6) Shutdown my machine, re-plugged my machine to have internet access again, and powered on
7) Ran the Windows hide / show updates application
8) Found nVidia driver it was planning on updating to
9) Marked that update to hide / don't install

I'll report back here if I end up back on square one.
There is no better way to defeat your enemies but to slice and dice em right Link?...oopz forgot you can't speak. Well I guess a simple head nod is sufficed.

User Info: SinisterSlay

SinisterSlay
4 weeks ago#7
You can disable all driver installs through group policy editor. Or simply disable the windows update service and wait for better drivers.
He who stumbles around in darkness with a stick is blind. But he who... sticks out in darkness... is... fluorescent! - Brother Silence

User Info: blacknight06

blacknight06
4 weeks ago#8
I have Windows 10 and they never update my drivers automatically. You sure it's not the Geforce Experience app? I don't have that installed ever since they changed it.

User Info: Elephant Rider

Elephant Rider
4 weeks ago#9
https://support.microsoft.com/en-us/help/3073930/how-to-temporarily-prevent-a-driver-update-from-reinstalling-in-window

If you download the "Show or Hide Updates" troubleshooter package, you can select updates and make Windows not show them. It works for quite a few different drivers that you probably don't want Windows to auto update. Been using it since day one.
little grey men are coming our way
tastes just like chicken they say

User Info: Marikhen

Marikhen
4 weeks ago#10
Lilrosco posted...
I'll report back here if I end up back on square one.


You'll be back to square one in about 30 days based on my experiences, if you don't disable driver or all updates first. You pretty much have to forgo things like system updates, plug and play component driver updates, and so on if you don't want to fight tooth and nail with Windows to keep older drivers around.

I had a real fun time with Windows 10 and my GTS 450. Only drivers that wouldn't result in PhysX being disabled due to having an active AMD HD6870 in my system were the 314.22 drivers that were released before even Windows 8.1. They worked just fine under Windows 10 and let me use hardware PhysX, but Windows didn't like that.

Shortly after getting Windows 10 up and running I installed the correct drivers, and Windows 10 disagreed with me. A reboot, a driver uninstallation, another reboot into safe mode which isn't as practical as in older versions of Windows because <reasons>, a DDU cleaning, yet another reboot, a reinstall of the correct drivers, and one more reboot, and I was good to go. For 30 days.

At that point Windows 10 announced that it was going to update my drivers, and the hide update utility proved to be so much crap at that point by not working to hide the update before Windows 10 bludgeoned my PC into submission. After a few days of futilely trying to prevent the update from going through without disabling all (driver) updates Windows went ahead and installed them anyway, and from that point on any game that used hardware PhysX generated a blue screen of death.

I gave up on Windows 10 at that point. Why use an OS that goes out of its way to sabotage your PC (experience)?

blacknight06 posted...
I have Windows 10 and they never update my drivers automatically. You sure it's not the Geforce Experience app?


Oh it's Windows 10. Windows 10 will update anything and everything that it feels it has a responsibility to update. I quite frankly expect that it will automatically update any and all Microsoft software such as Office or Visual Studio on your PC as well.

Elephant Rider posted...
https://support.microsoft.com/en-us/help/3073930/how-to-temporarily-prevent-a-driver-update-from-reinstalling-in-window

If you download the "Show or Hide Updates" troubleshooter package, you can select updates and make Windows not show them. It works for quite a few different drivers that you probably don't want Windows to auto update. Been using it since day one.


Down side to that is that it doesn't work proactively. You can only use it after the initial installation. :-/

Well, either that or the software randomly breaks and starts refusing to do its job as evidenced by its not working to hide an incoming driver update.
Logic is the antithesis of faith, else why is it that faith defies logic while logic denies faith?
  1. Boards
  2. PC
  3. How to stop windows 10 from updating nVidia Drivers?

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived