Major Fable 2 Glitches FAQ - the final version

  • Topic Closed
You're browsing the GameFAQs Message Boards as a guest. Sign Up for free (or Log In if you already have an account) to be able to post messages, change how messages are displayed, and view media in posts.
  1. Boards
  2. Fable II
  3. Major Fable 2 Glitches FAQ - the final version
(message deleted)

User Info: PiMacleod

8 years ago#422
I barely ever post online, anywhere. But, there's enough glitches in this game to get me to type this time...

Right after the Crucible, I decided I was going to play Fortune's Tower in Westcliff. Don't know why, just wanted to (that's probably my problem right there). I got a jackpot, paid my 200 chip debt, and exited Fortune's Tower. The first thing I see (besides my character and all the familiar surroundings of the tavern in Westcliff) is that I got the Plaits Hairstyle card. Weird.

And I got it again. And again. And again. Repeat. Forever.

I hit the A button to accept it, and it gives me another. I can use the Y button to Flip it, like normal, but that doesn't mean a thing obviously. Start just accepts the item, much like the A button. I basically have an infinite loop of Plaits cards, and I can't go anywhere or do anything but accept them.

I even went to the dashboard to try to load up the file again. Of course that doesn't work -- the game just had to go an Auto-Save me as I was exiting the Fortune's Tower game, thus, I'm still receiving Plaits Hairstyle cards.

And to think, I was really liking this game, but this is my 2nd major glitch. I've already gotten all the Pub Games special items and merged them onto this character.... I'm not doing that again! I'm not expecting help on this, because it seems pretty bleak, but does anyone know what I can do to fix it? know, besides starting a new character. sigh.

User Info: rhys74

8 years ago#423
Yay I got hit with the disappearing spouse glitch. My husband went missing for a long time, leaving my son alone in the Serenity farm. When I defeated Lucian I couldn't clear the quest when you're supposed to return to your family. Guess I'm not going to play this game any more until they patch it to fix some bugs. At least I hope they fix some.

User Info: PhilR1

8 years ago#424
I completed the game a couple of nights ago and think I was very lucky that I didn't get many glitches. I only got two in the whole game - the marital home glitch and the child glitch which makes your child just stand outside the house.
I was very concerned about getting the hero Of Skill glitch people have mentioned here but when I eventually met Reaver I didn't even have to get anymore renown points and went straight to Wraithmarsh. It got me thinking of how that could be and the only answer I can think of is that I got The Celebrity achievement which you get after 50,000 points so for those of you who are worried about playing the game for hours and having a gamebreaking glitch, maybe it's a good idea to go for that achievement before meeting Reaver. It's not that difficult to get because most of the sidequests you get when you go to Bloodstone give you around 7000 renown points each. A visit to the Bard to get him to sing songs about you and saving slavers will easily get you enough renown points to get the achievement.

I have been wondering if it's Alex from 'Til Death Do Us Part' quest that starts the marital home glitch. A couple of my friends have had the same thing happening to them after Alex divorces you or could be just your first in-game marriage ending up in divorce which starts the glitch?

User Info: monicapo

8 years ago#425
"As you know, the world is affected by your action, so after certain events in the
game if you decided to do some good things a new place will open up"

What places open up after you do good things? I thought everything's story-based.
A few years ago, Square = Good games
Now Square = Final Fantasy spin-off #54

User Info: longtermfx

8 years ago#426 Items not appearing in the chest

After much research I have found how to solve this. You must start a NEW game with a NEW character and go through the 20 minutes of **** talking until you get into the Old Town (Guild Cave) where the chest is located. Open the chest with the new character and acquire the items and save your game. Then, go back to your old character, and go into one of the shops and begin to purchase the items. This was one of the most aggervating things I have come across.

Crucible Glitch

After beating the crucible with 8 perfect rounds and acquiring "The Chopper", when I attempt to play through again and get 8 perfect rounds I become frozen. After the 8 rounds, it directs you to the same chest the chopper was it, and when you try to open it, it just throws you to a loading screen and you end up outside the crucible frozen. I have tried countless possible solutions but none work. Here's my advice, the next patch should allow you to ALSO EXIT the normal way out of the crucible. This pissed me off as I have broken my record with a time of 4:11 and I can't log it in my stats. lame... Also, I set the crucible as my active question so I can just travel directly towards it, now there is no way to get it un-highlighten in my Quests menu.

House Doors

There have been several occasions where I would open a door and it would get me lodged behind it and I couldn't get out. The only way to get myself out is to travel to a different region or the same region I am in. RETARDED!

People Get me stuck

Last night when I was playing with one of my buddies, I decided to walk down an alley to go and dig up something my pooch was barking about. When I tried to exit, I had a group of children asking me for my autograph. I attempted to just run past them and ignore them, but for some ODD reason I couldn't get around them. I tried to use the time warp spell, i tried to scare them, I CAN'T kill them so I couldn't get rid of them, and once again... the only fix was to travel to another region. LAME!

Auto-Save turn off feature

Where the hell is the feature to turn off auto-save? There is one in just about every game that uses it, where the hell is fable 2's? It should only auto-save whenever your trading items between online players. This feature has frozen several peoples gamedata due to glitches and bugs. they need to add this feature in a new update.

Copy Save game file

I want to copy my save game file so I can go between my girlfriends and my house, but its seems the developers are to paranoid and removed this feature from working. this isn't really a glitch, but it's a complaint.

Broken shop/house windows

If you break the windows of a shop or a house, they never repair/get rebuilt. No matter what I have done, I have yet to figure out how to repair these broken windows. This is stupid, people repsawn but windows can't? fantastic.

User Info: luke2460

8 years ago#427
^^^ Your crucible glitch also happened to me...i also beat my record time (even though i had already gotten the chopper). The chestt was still closed and when i opened it the same thing happened to cant b fixed i tried evrything! New game....

So i started a new file yesterday and the dog is already stuck on the underside of the his way through it....stupid dog! So yeah...he hasnt come out yet but im hoping he will b behind me when i leave the area...

User Info: IamMaz

8 years ago#428
I finished the game the other day and I think I've been lucky not to have any major glitches.

I had the glitch where my child just stood outside my house doing nothing. That eventually fixed itself.

Another glitch I had which I don't think I've seen posted was that, after using the expression wheel, I had a white crescent circle where the edge of the (i think) 'rude' expressions option is. This was just there slightly off centre in the screen. This went away when I restarted the console.

A third glitch I got (well, my housemate got this one but it was on my xbox and my copy of Fable) was that we won a double bed from the Westcliff shooting range and a message came up at the top of the screen talking about furniture shops and decorating houses and satyed there. It would occasionally be replaced by mission text but once that text had gone it was back at the top of the screen again. Whilst it was there, the screen poition seemed to shift downwards so, for instance, we couldn't see the sword being hammered during the blacksmith's job. I'm not sure if this glitch has gone yet.
Young, female gamer searching for eye catching sig with GSOH. Experience not necessary. Apply through profile.

User Info: Gloobert

8 years ago#429
My character got glitched with a "no lock on" problem. For some reason, when I press the left trigger, I cant lock on to anything anymore... villagers, enemies, etc. I cant marry or anything like that.

Every time I press the left trigger, it just zooms in but doesn't target anyone... Extremely annoying and I lost about 20+ hours. :(

I have the same problem. Hopefully I can get through as much as I can, it sucks so bad not being able to accept gifts or proposition someone for sex.
No one has the right to be heard

User Info: C-Lee

8 years ago#430
Anybody help me here? i Beat the quest with the two idiots,where i kill 100 zombies, beat it, talked to them, and i finished the quest, except im stuck in scene mode. I cant finish the scene!
  1. Boards
  2. Fable II
  3. Major Fable 2 Glitches FAQ - the final version

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Closed