This is a split board - You can return to the Split List for other boards.

PS3 Controller bug with R3 button (UNKNOWN BUG)

  • Topic Archived
You're browsing the GameFAQs Message Boards as a guest. Sign Up for free (or Log In if you already have an account) to be able to post messages, change how messages are displayed, and view media in posts.
  1. Boards
  2. PlayStation 3
  3. PS3 Controller bug with R3 button (UNKNOWN BUG)

User Info: Fredioz

4 years ago#1
Lately, something very weird has been happening to my controllers. The bug appears to happen when playing Skyrim, although I think that it might not be the only game that makes it happen. To keep it short: To change the camera mode, by default, you press the R3 button, the problem is when you hold the button down and realize "Holy moly, I'm screwed".
So each time that happens, if you are in the 3rd person camera, you toggle the option to customize it, and since I have let go of the R3 button, I can't stop that from happening. Now you might be thinking I should have posted this in another topic, probably in a Skyrim bugs one, but the real problem starts after that. I naturally exit the game, as it is very close to unplayable with the camera wobbling all around, so I pause the game and exit it. I then plug my controller into my compuyer and use a handy tool (Motioninjoy's DS3 Tool) to try to figure out what is happening. As I open the controller panel in the program to see if every button is working naturally, I notice that the R3 button appears as if it was being PUSHED DOWN. Now I would have never been able to figure it out, since the R3 button appears as if working normally on the outside. I have tried resetting the controller, but it stays the same. Now, I had already experienced this problem a few days ago, and it was HORRIBLE. I thought my controller had a problem, so I dismantled it. Every single piece was in place, including under and over the microchip. I proceeded to close it all up, when one of the red power wires snaps. That's one perfectly fine controller to the trash, as I reconnected it back into my computer and used the program to see if everything was ok and the two only working buttons were R3 and L3, that's when I figured I had cut out one of the red power wires.
I have written in the title "UNKNOWN BUG" because I miserably surfed the internet looking for someone with a problem like this, but all I found were ignorant posts about people asking "What is the R3/L3 button on my PS3?" and R3 buttons popping out of place.
I had found ONE post with someone that experienced this problem, although they stated that after spending some days without playing and then doing it, everything was back to normal.
This is far more extensive than it should be, but then again this is one complex bug.
To sum it all up, on account of this bug, I lost one perfectly good PS3 controller and the other one still has the bug with the R3 button, as it is working perfectly fine but appears as being pressed down, even when it is not.
Hope it was not too confusing, I will be constantly checking this post to see if anyone has answered and if you took the time to read all of this, thank you and please reply with your opinion/fix/suggestion,etc.

User Info: dankanefan

4 years ago#2
I read the whole thing. You might want to add some spaces to make it easier to read. Anyway, the controller wire breaking thing sucks. I don't take controllers apart because they are too hard to put back together without screwing something up. So I feel for ya there.

As for the bug, I think you are making a bigger deal out of this than it is. Have you tried it with other games that need R3? Also, how new/old are your controllers?
Sac City Gamer -
@SacCityGamer ~

User Info: reincarnator07

4 years ago#3
Paragraphs. Use them. TL;DR
Fan of metal? Don't mind covers? Check out my youtube and give me some feedback

User Info: _CARLOX_

4 years ago#4
There's no fix. Your R3 buttons broke (maybe for pressing them too hard?).

If the controllers were doing the same thing when connected to a PC then it is not a bug, you just need new controllers.
  1. Boards
  2. PlayStation 3
  3. PS3 Controller bug with R3 button (UNKNOWN BUG)

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived