The Mercenaries 2 Glitch FAQ

You're browsing the GameFAQs Message Boards as a guest. Sign Up for free (or Log In if you already have an account) to be able to post messages, change how messages are displayed, and view media in posts.
  1. Boards
  2. Mercenaries 2: World in Flames
  3. The Mercenaries 2 Glitch FAQ

User Info: Daedalaus

8 years ago#151

Land a huey on the back of a transport ship, then try driving the transport ship, it'l get bogged down at the back and just start rising out of the sea like the god damn titanic did, absolute waste of time.

Numerous amount of times friendlies just start shooting at me and even start radioing base to tell them im killing them all, when ive done absolutely nothing.

Numerous times enemies are stuck in walls, dont do anything, and just generally act like idiots.

Once someone who was radioing base to 'tell' on me was stuck in a rock, i could see the flashy thing above his head and hear him talking, but by the time i realised he was actually IN the rock i had no time to get away. WAHAY!

What makes me laugh is there havent even been substantial updates to the game to sort this **** out, and people still give it more than a 5?

User Info: BurgerMyster

8 years ago#152
I have no idea how this happened. I came across a glitch where all the enemies in the game couldn't fire their weapons at me. Foot soldiers could still hit me, but every enemy and enemy vehicle in the game couldn't shoot anything at me. I managed to beat half of the game with this glitch in about 3 hours.

User Info: themightyOdin

8 years ago#153
i have found a glich not sure if its been reported yet...
on the mission where you hsveto go back to the pmc to save it, i was playing a coop game as when i hijacked a tank my coop player shot it as i got in it accedentally and the take blew up but i was stuck in the same possition as if i was in it but frozen.

User Info: razorfett147

8 years ago#154

Craziest stuff I've seen so far happened recently when a buddy of mine was playing co-op with me. During the mission where you first attempt to go after Solano, something glitched badly........causing any motor vehicle my friend entered to begin barrel rolling and banging wilding into the ground. On his screen, it just looked like the car was shaking and pieces of it were inexplicably falling off. On my screen, his car looked like it was getting ravaged by an invisible T-rex.:lol: This was all very amusing until we started actually trying to play thru the mission. At one point, we both had to get into the same vehicle......and all hell broke loose. Needless to say our commandeered ride survived the violent thrashing for all of about 5 seconds before suddenly exploding and hurling us both several dozen meters. We were unable to complete the mission for lack of him being able to get into a vehicle that could survive long enough to get back to the PMC in time. And whenever he tried jumping into a would refuse to move; as though it were trying to tote a load much too big for it via the winch.

Even more hilarious is that during the course of that play session (at some point which I'm not sure about) his character became permanently equipped with the red flare gun used for calling in an aquatic vehicle. This was only visible on my screen (he could still see the actual weapons he was really using). I had a huge WTF moment the first time I saw him charge an enemy encampment armed with nothing but a flare gun........firing off multiple flares into the air....which resulted in multiple explosions on the ground in front of him (he was using the GL on his screen).

Crazy stuff.8)

User Info: boyscout1025

8 years ago#155
A crazy glitch happened to me yesterday. I was driving off a skyscraper with a Panzercycle, tried to land with all of the tread landing on the ground at the same time, and then, all of a sudden, I went through the ground, and landed in a pocket underneath. It was entertaining to drive around and stuff, but I couldn't get back up. I noticed an invisible area, and I walked toward it, and then I fell into an endless abyss. I had to reload the save. Plus, there was an area with a stretched out texture. Crazy, huh?
Buy a pizza and nobody will be hungry, and make sure that it's a pepperoni and thick crust.

User Info: Extradaemon

7 years ago#156

does anyone know how 2 fix the pistol held like a rifle glitch yet

User Info: jakatackka

7 years ago#157
I have a few things to say:

1) How the betting system works in the Winching Challenge is that the minimum wager is 5% of your money and the maximum wager is 20% of said money. However, due to a glitch, once you pass $100 million, the maximum stops rising, but the minimum does not stop rising. I like to take full advantage of this glitch. I know this is random, but I haven't seen it anywhere else.

2) I just had the character-switch glitch happen, but I found out (literally 2 minutes ago) how to fix it. This requires multiple save files.

a. If the file you usually play as is the most recent one and you find yourself in your oldest file, pause immediately and check your save files. If the times and dates are right, don't worry - it's probably a harmless glitch. The save files (at least on mine) just LOVE to randomize their own dates and times, but usually no harm comes out of this. If, however, the times and dates are wrong, then you can continue at this stage - this is usually a harmless glitch and happens all the time without consequence.

b. Go back to the main screen and load your save file manually. This is usually where the glitch happens. Your file loads, when OHMIGOD THAT'S NOT ME! The best thing to do is either go to the Xbox Dashboard or shut the system off and reboot it. Go to the system settings and fix the time. After it is set, load the game. Then just load it from the "Manage Saves" menu, and wha-la! Your character is normal!

Other weird glitch associated with the character switch cheat - if you are wearing an outfit other than default, your new glitch character will also be wearing that outfit. That happened to me because on my Matthias file I had an outfit I didn't have on my Chris file, and it took me five minutes to figure out who this strange black guy I've never seen before was.

3. You know that random vehicle-exploding cheat? Well, I've found a couple of things similar to it.
a. Random vehicle damage glitch (randomly takes 60 damage, sending trunk and hood flying off randomly)

b. Not-so-random vehicle explosion cheat. Why is it "not-so-random?" You know that mission for the Pirates where you have to complete their smuggling route on the Little Dimba (Pirate jetski)? There are two checkpoints directly after navigating the minefield, and halfway between the first and the second while passing the island my vehicle randomly exploded! This happened in the exact same spot 3 times! The level didn't matter - just the location.

c. Oh, and I noticed a lot of people have been saying that the random vehicle explosion cheat only happens on online. Well, it happens in single player. A LOT.

User Info: jakatackka

7 years ago#158
Sorry, I know double-posts are bad, but I just remembered a few other glitches.

1. Oftentimes, a person in a building that shoots rockets will suddenly switch weapons and suddenly be frozen, standing partly on an invisible ledge and partly within the wall, all while holding a pistol. I think this happens because the heavy infantry either have an RPG and a powerful rifle (varying between factions) or an RPG and a pistol, and due to some glitch, it spawns the wrong guy and when the guy switches weapons he freezes. This doesn't just happen in the mini-bases marked on your mini-map by a black diamond - it also happens in the big buildings with craters on the sides that the enemies come out of.

2. When driving a vehicle, sometimes you'll hit a tank and take WAY LESS damage then usual (like 1 or 2), but then you'll ricochet into a tree and take 50 damage! I didn't know buildings and tanks had piezoelectric armor! Again, single-player.

3. Sometimes, you'll park on a balcony near the guardrails, and as soon as you exit the vehicle it'll be sideways, at a 45 degree angle straight into the ground, and be sticking out of the guardrails. When you get in, it'll stay in this position until you drive off.

4. Usually, if you enter a building and exit your nearby vehicle (or vehicles) will be repaired and rearmed. However, rarely, the vehicle will just disappear! Or you'll go out and see somebody from your base suddenly jump in and drive/fly away!

User Info: flemwad1

7 years ago#159
I'm playing on a PC with Windows 7. Everything works great except no one attacks me while I am walking around. If I am in a vehicle everyone showers me with bullets like I was in Afganistan. But outside the vehicle no one shoots at me. This isn't so bad, a little boring, but the real problem comes when people have to follow me, cause they don't. I can talk to em and shoot em and stuff but I can't actually get them to follow me. Its like I'm a ghost mercenary, which would be a cool spinoff, if anyone cares. Any help?

User Info: PSN_kyzage

7 years ago#160
Sorry if reapeated
One of the AN "destroy targets" target was at the chinese base, i went there and it's a tank hanger, I fly over after destroying it and a tank spawns, gets stuck and explodes shooting it up in the air, over the other side of the road and lands on a leaping fox destroying it and killing the chinese inside and this happened like 2 mins ago it's still paused on my screen 0_0
  1. Boards
  2. Mercenaries 2: World in Flames
  3. The Mercenaries 2 Glitch FAQ

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.