Error 12

  • Topic Archived
You're browsing the GameFAQs Message Boards as a guest. Sign Up for free (or Log In if you already have an account) to be able to post messages, change how messages are displayed, and view media in posts.

User Info: cjs812

5 years ago#1
When I try to save my game, a pop up appears and says that an unexpected problem occurred while saving, error 12. I checked the readme.txt and it said that error 12 is an "World file save failure."

Is there anything I can do about this? I don't feel like calling customer service.
cjs812 has posted.
This thread is now important.

User Info: nihonjin_ningyo

5 years ago#2
This is what I did to fix it. Never messed up again. I get this from a forum post on sims 3 forum.

The only way I could get rid of periodic Error code 12 problems was to enable access to more than 2 GB of memory (I have 4 Gb installed). I had to update to all the latest patches (versions 1.19.44/2.14.4/3.10.4/4.7.4/5.5.4/6.2.4) After this, I have not had any more Error Code 12 problems.

For your system, it depends on your operating system (XP, Vista, or Windows 7 and whether it is 32 bit or 64 bit. I recommend you have at least 4 GB of memory. For 64 bit Vista or Windows 7, the latest versions of Sims 3 can use more than 2Gb of memory already. For 32 Bit you have to enable access to more than 2 Gb memory on startup.

Here's what I did. My system is 32 bit Vista which as installed only accesses 2 Gb of memory. I had to install at least 4 Gb of memory and do the following to allow a 32 bit operating system to address more memory (from Mod The Sims/Sims Wiki page):

1) 32-bit Operating Systems
If you have a 32-bit version of Windows, and additional step is required in order for The Sims 3 to use more than 2 GiB of virtual memory. You must have at least 3 GiB of RAM installed in your system before taking these steps.

For Windows Vista, Windows 7, Server 2008
Open the Command Prompt with administrative rights.
Open Start.
Open Programs.
Open Acessories.
Right-click on Command Prompt and select Run as Administrator.
Type the following and hit enter:
If you have 3 GiB of RAM installed: bcdedit /set IncreaseUserVA 2560
If you have 4 GiB of RAM installed: bcdedit /set IncreaseUserVA 3072
Close the command prompt and restart your computer.

If you have XP, here are the MTS instructions:
Windows XP, Server 2003
Open System Properties.
Right-click on My Computer and select Properties.
Select the Advanced tab.
In the Startup and Recovery area, click Settings to open the Startup and Recovery dialog.
In the System Startup area, click Edit to open the Windows boot.ini in Notepad.
Make sure to disable Word Wrap from the Format menu (you do not want a check to appear next to it).
Find the [Operating Systems] section. Each line below this header represents an operating system installed on your computer.
At the end of each line under [Operating Systems] add the following after /fastdetect (or whatever is at the end of the line):
If you have 3 GiB of RAM installed: /3GB /userva=2560
If you have 4 GiB of RAM installed: /3GB

I think it is very poor EA game design that you have to make changes like this in order to prevent this problem.
Save the changes and close Notepad.
Close all open dialogs and restart your computer.
PSN: hanguk_nihon

User Info: Shaidon

5 years ago#3
Some others says that you need to limit the memory.
This issue have many ways to "fix" it, unfortunate.
That is EA to blame, to make a game that don't deal well with that many expansions and AI that eat up your CPU.

Here is what happened to me. It was everything OK for a while. I decided to use a mod to allow me to run without the need of DVD and was executing the game from the TS3.exe for that to work. It was fine for a while, until I start to get this error. What was a pain at the first time, since I didn't saved tha entire trip to China.
So I stop using the mod and went back to how it was. And I didn't got the error again. But since Murphy Law always happen, I might get it again after this post. XD

Another solution that I have in my pocket is, instead of using the normal save, use Save As... And see if I can create a copy.
Also, best to save often. Another reason some warn about is that since you didn't saved for a while, a lot of things that you did are in the memory, and the game don't have enough space to do the processing of writing it in the old save.
50% of the challenge is made by the game. The other fifty, by the player.

User Info: scottrand05

5 years ago#4
To be fair, it's not EA's fault that 32 bit systems aren't designed to use more than 2G of memory; that's MS's fault. However, it is EA's fault when they say that you can run this with only 2G memory when you actually need more (though to play Devil's Advocate, most people are using a 64 bit OS).

Another solution that I have in my pocket is, instead of using the normal save, use Save As... And see if I can create a copy.

This is what I do ALL the time, and I have a 64 bit system with 4G and don't use either the DVD or the launcher.

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived