Troubles with original NWN 2 after installing SoZ

  • Topic Archived
You're browsing the GameFAQs Message Boards as a guest. Sign Up for free (or Log In if you already have an account) to be able to post messages, change how messages are displayed, and view media in posts.
  1. Boards
  2. Neverwinter Nights 2: Storm of Zehir
  3. Troubles with original NWN 2 after installing SoZ

User Info: shalock

8 years ago#1

Good day to everyone!


Id like to ask if anyone has the same problem as me. I adquired SOZ and decided to install all the NWN2 saga, i started playing this from the beggining but its give me a trouble after i enter the first time to the Sunken Jar.

 After i speak with uncle Duncan i cant exit the tavern, the game always crashes, when i try to reload some of my character dissapears, im playing with an human ranger if it has anything to do.


Thanx for any help

User Info: Peeps Bucket

Peeps Bucket
8 years ago#2
Try this: Exit the tavern with only one character selected. I would get crashes during certain area transitions if I tried to leave with more than one character selected.
Peepsbucket: persnickety, prepubescent, peps, seersucker, pees, preps, precepts, preempts, Pepsi, PepsiCo, apexes, applesauce, beeps

User Info: myztikrice

8 years ago#3
This was due to a problem with the party selection screen. It was fixed in the latest patch.
"Think of how stupid the average person is, and realize half of them are stupider than that." - George Carlin

User Info: shalock

8 years ago#4
Thanx ill look for the latest patch for SoZ

User Info: mojs

8 years ago#5
I had the exactly same problem, unable to leave the Sunken Flagon after installing SoZ.

Latest patch did not seem to solve it for me either, so I got really anyoed and fixed it myself. If anyone is interested in this fix (no guarantees given) then give me a note. I could possibly also make a quick tutorial on how to patch yourself, but I think it will be hard to follow without some basic computer programming knowledge.

(technical part, skip if you like)

The issue was a read from address 0, an exception gets raised by the OS/CPU and the program is normally closed down by the OS (the program crashes). However, I did hook up NWN2 to a debugger, found the location of this faulty memory read and patching it so it only reads if the address it something else then zero. And I have managed to progress beyond the Sunken Flagon ;)

User Info: Gigelf

8 years ago#6
Im having this same issue. Can you post a fix for those of us who have no idea of programming?
"El camino de la irresponsabilidad no conoce la melaoncolia"

User Info: JohnWho08

8 years ago#7
I've made a fix which solved the problem for me, it takes care of the problem mojs describes.

This was a quick fix so it only works on fileversion which is the latest cracked exe i believe(by ViTALiTY). I updated to latest game version with nwupdate.exe and then replaced the executables with those from the ViTALiTY release.

Start testfix.exe
Start game
when game is running press numpad0 to activate fix

you should now be able to leave the "Sunken Flagon" after the speach with duncan!

Hope this helps, else let me know and i'll try fix it.


User Info: jaydana

8 years ago#8
Hi there, I also thought I was doing the right thing when I went out and bought Mask of The Betrayer and Storm Of Zehir and loaded them all at the same time even though I hadnt completed the original NWN2 (my son plays it also) my son says the game is "stuffed" because when he is trying to beat Black Garius and his Nightwalker the game just plays over and one dies in battle and it just plays on its own repetitively..he cant get past this battle..his players heal themselves and Black Garius never dies..HELLLLLLPPPPPPP....when I loaded the new games, they searched for the latest versions and patches themselves so I would have thought they would have the newest patches, versions available????...omg what have I done...????? how do I fix this???

User Info: jaydana

8 years ago#9
Me again, just a further update on my dilemma, my son said that Nightwalker never shows up..obviously a gameplay glitch caused by loading the expansions on top of the game? Also, can someone please tell me what these 2 expansion packs actually do? if my son is nearly at the end of the NWN2 game, do these expansion packs now give him new storylines/adventures etc after the original game would have finished???? im a little confused, its not like Age Of Mythology etc, where they are individual games that you can click on. Do you have to have a certain disk in at the time of playing? does it matter if its NWN2 (original) or one of the expansion disks? does that make a difference???..wish I had never bought the damn expansions now..grrrrrrrrr

User Info: JohnWho08

8 years ago#10
Game should load fine with any of the disks. When pressing "new game" you can select between the original game story or one of the expansions.
  1. Boards
  2. Neverwinter Nights 2: Storm of Zehir
  3. Troubles with original NWN 2 after installing SoZ

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived