Sacred 2: Lost Angels CO-OP Mode: Mount has gone MISSING

  • Topic Archived
You're browsing the GameFAQs Message Boards as a guest. Sign Up for free (or Log In if you already have an account) to be able to post messages, change how messages are displayed, and view media in posts.
  1. Boards
  2. Sacred 2: Fallen Angel
  3. Sacred 2: Lost Angels CO-OP Mode: Mount has gone MISSING

User Info: DragonlXl

7 years ago#1
Hi, I bought a PS3 for my mom, and SACRED 2 : Fallen Angels, as Hack & Slash is as much as she can play. We play Co-OP and have our own characters, which both have mounts. We've saved the game, and when reloading. Like Normal We've been taking turns on each others story's. But Lately when we log in the 2nd player. It's MOUNT is MISSING!!! and when we got to buy a new one for the 2nd player we can't.. If u check inventory, it shows no mount too!!!!. So WE"RE Stuck!... No MOUNT, Can't Buy a NEW ONE!!!!... what to do... I bought the game from Electronics Boutique. And the instructions it came with are in FRENCH... Am I missing something simple... PLZ HELP... Kinda choked at the game.... Also, Both players Are logged into the Playstation Network... Figured it was that so we made a 2nd account for the second person to log in with... Both players when starting enter password for PS Network etc.... STUCK PLZ HELP!


User Info: DragonlXl

7 years ago#2
ehh hope this doesn't affect the replys.. Put the wrong titile... Its Obviously supposed to be.... Sacred 2: Fallen Angel

User Info: backguard222

7 years ago#3
I don't think you are missing something simple. The game has some bugs, although I've never heard of this one. I assume you guys have tried buying mounts in both of your games?

User Info: backguard222

7 years ago#4
You could also try going into free world and completing the quest again.

User Info: EvilDead

7 years ago#5
Same thing happened to me. Go to the last resurrection point you activated, and try to summon the mount there. It should arrive.

User Info: cbGamer4life

7 years ago#6
You co - op with your mother o_O

Cool parents :)

User Info: backguard222

7 years ago#7
did you fix the problem?

User Info: craazy

7 years ago#8
I had this problem also.....SO I just bought a horse and it worked....would rather have my super mount but the horse functioned ok
Fly Talkin Skywalkin - Like a Ninja!!!!
PSN: Craazy

User Info: Anagura

7 years ago#9
Me and my flatmate had this problem too and after playing around we figured out how to SOMETIMES get 2P's mount to show up.

The easiest thing to try is:
1: log in with player 2
2: check if you can summon mount
3: Log out with player 2
4: Log back in with player 2.

This sometimes worked for us, however when it didn't we fluked it by (unknowingly at the time):

1:In P1's account, get to a teleporter (savepoint thingy) and activate it
2:Save and quit
3:Go into P2's account in the XMB and start the game
4:Get to the VERY SAME teleporter and activate it
5: Go back into P1's account
6: When 2P joins the game, 2P's mount should appear where you left it in their profile.

This leaves me to believe you have to dismount it near the save point in 2P's profile, I can't remember whether we did or not. experiment a little. I hope this helps.

This game might've been more fun for us if we didn't spend more time trying to figure out things like this than actually playing the game.
  1. Boards
  2. Sacred 2: Fallen Angel
  3. Sacred 2: Lost Angels CO-OP Mode: Mount has gone MISSING

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived