Can't register on website

  • Topic Archived
You're browsing the GameFAQs Message Boards as a guest. Sign Up for free (or Log In if you already have an account) to be able to post messages, change how messages are displayed, and view media in posts.
  1. Boards
  2. Star Wars: The Old Republic
  3. Can't register on website

User Info: NauticalDisasta

NauticalDisasta
5 years ago#1
So I wanted to give this game a try now that it went F2P. I go to the website and click on the "Play Free Now" button. When trying to create an account, it won't accept any username I try to input. I mean any username. I've tried the most random crap and it just keeps saying "name invalid or unavailable".

Has anyone else had this problem? Does anyone have any suggestions about how to solve this problem? If it helps, I already have an Origin account. The free to play model doesn't seem to be available through their store though.
"Getting lost in the light is more than never being found." - Gordon Downie
360/PSN/Steam= NauticalDisasta

User Info: FarronXIII

FarronXIII
5 years ago#2
got the same issue here. weird.
Official May of the Pokemon Black 2 Board
Currently Playing: Pokemon Black Version, Dissidia 012 Duodecim - Final Fantasy, Persona 4, Final Fantasy VIII (PSN)

User Info: AstroApe

AstroApe
5 years ago#3
I can log in to the game, but can't log in to the site to buy currency or work my account. Seems related.

User Info: trejodunesea

trejodunesea
5 years ago#4
I figured out why. No matter what you start writing, it will always display "Name invalid or unavailable." However, if you fully type out a name that's not already taken, and that's acceptable, and then click in another box (like password), the message will go away.

User Info: eureca323

eureca323
5 years ago#5
I just tried to register for free to play and have the same problem. I can type in random numbers and letters. Or the username I want and add random numbers to it. Anything I put in I get the "Name invalid or unavailable" message.

Even if I go to the next box like mentioned it still shows the message and I can't press the play now button at the end to register even if I entered everything else.

Ill try later, but if anyone knows whats up please do tell.

User Info: pyber80

pyber80
5 years ago#6
No problem here, unless I try to use numbers.
http://i.imgur.com/88bcI.jpg http://i.imgur.com/lH2Zc.jpg
http://i.imgur.com/2FjLt.gif http://i.imgur.com/JF1HR.gif

User Info: eureca323

eureca323
5 years ago#7
Ah thanks. Yea it doesn't seem to accept numbers. Usually add numbers when my username is taken. Was able to register with an underscore.

User Info: Will446

Will446
5 years ago#8
I had a simliar issue when paying for the game for two months. Pretty much this error has been going on since launch.

User Info: mas5949

mas5949
5 years ago#9
I have been trying to get my email validated so I can try to sub for a month and see if the benefits are worth the fees, but every time I try I never receive the email.

User Info: pyber80

pyber80
5 years ago#10
Will446 posted...
I had a simliar issue when paying for the game for two months. Pretty much this error has been going on since launch.

If you were already active and playing then its not a similar issue, since this has to do with initial account registration and not existing active account services (which have had their own separate issues off and on since long before launch). And if this had been going on since launch, I probably would have heard about it before now, so its either entirely new with 1.5/F2P, or was exceedingly rare before, to the point where even someone like myself, that tries his best to keep up with things, hasn't heard of it being an issue.
http://i.imgur.com/88bcI.jpg http://i.imgur.com/lH2Zc.jpg
http://i.imgur.com/2FjLt.gif http://i.imgur.com/JF1HR.gif
  1. Boards
  2. Star Wars: The Old Republic
  3. Can't register on website

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived