Why does the clock in the game doesnt work?

  1. Some of the events doesnt happen like the tide in the shoal cave, the mirage island, etc.

    Pls. help me!!

    User Info: Kamiya03

    Kamiya03 - 8 years ago
  2. Clarification Request::
    When I start my game, it says "The previous save file will be loaded. The game can be played." It doesn't say that the clock battery is dead, but time still doesn't pass. The in-game clock won't change, but there battery is fine. Can someone help?

    User Info: simonbelmonthed

    simonbelmonthed - 3 years ago
  3. Clarification Request::
    @simonbelmonthed Same with me but I play on my ds

    User Info: ShimoFrost

    ShimoFrost - 3 years ago

Top Voted Answer

  1. If you are using an emulator, you may or not use the real time clock option, but if you are using a gba, it may be the clock bug, wich can be corrected by connecting the game with a gamecube.

    User Info: Arkmenhah

    Arkmenhah - 7 years ago 1 0


  1. Your Battery is dead nothing we can do

    User Info: RaikouTGC

    RaikouTGC (Expert) - 8 years ago 1 2
  2. 1st : the mirage island isnt all that special! Well,unless you're in love with Wynauts wich you can get in Lavaridge Town inside a frickin' egg!Oh,and a Leichi berry....
    2st:in the shoal cave's low tide you can get 4 shoal salt(i hate salt!)to make a shellbell and cach Snorunts
    Meh!the shell bell help you recover a tiny bit off HP by hitting a foe .I recommend get the Leftovers in the S.S Tidal AFTER you beat the Elite Four.

    User Info: Blaziking96

    Blaziking96 - 8 years ago 1 0
  3. Nothing is wrong with the battery, you set the clock at the beginning of the game, and it keeps time accordingly. it does NOT, however, change for daylight savings time

    User Info: squarefood24

    squarefood24 - 8 years ago 0 2
  4. The Internal Battery is dead. There's nothing more to it. But the mirage island isn't a time-based event so you can still get to it. You just need the right pokemon.

    User Info: ghimpitz

    ghimpitz - 8 years ago 0 0
  5. Noooooooo! If the battery was dead, then Kamiya would lose his/her save file. I lost my game due to a dead battery. So I had it replaced and wa-la. But of course if you take a look at my previous problem posted months ago for the very same game. "Time goes by but tomorrow never comes?" Well, I still don't know what's the problem, but the only solution I can think of is that perhaps it's that I got a bootleg copy. Idk about Kamiya but yeah.

    User Info: NooGai808

    NooGai808 - 7 years ago 0 1
  6. In Ru/Sa/Em the internal Battery only controls the Realtime Clock, Game Save data is maintained on Flash Memory and is unaffected by the Battery

    User Info: RaikouTGC

    RaikouTGC (Expert) - 7 years ago 0 0
  7. The internal battery has run dry. The game will still work,but clock based events will no longer work.

    User Info: Oho_Jee

    Oho_Jee - 7 years ago 1 1
  8. If you have at least 100 hours of play time on your save file, any events that are related to the clock stop working. For example, berries will not grow and tides will not reset.

    User Info: Decon082

    Decon082 - 7 years ago 0 2
  9. ^ Actually, that bug was fixed in Emerald.

    As for your problem, as everyone has said, your internal battery is dead, and you should actually be notified of it when you start up your game. If you're using an emulator, be sure that the "real time clock" option is unchecked.

    User Info: NismoZ2

    NismoZ2 - 6 years ago 0 0
  10. There are several possible causes for the time to not change.

    * On Ruby and Sapphire, the "berry glitch" may be affecting the cartridge. This can be fixed rather easily by linking with other games.

    * The battery may have run dry. In the GBA games, the battery running dry does not delete the savegame anymore. It does however stop the clock from working as the RTC-chip is powered from battery. You should receive a notification about that when you start the game. The battery can be replaced but you shouldn't try this if you're not very experienced with that kind of hardware stuff.

    * You may have a counterfeit game. If on every game start a message "The game can by played" is shown, that is a very safe sign that you don't have an original game. Counterfeit games often only have 64kb of savegame storage (instead of 128kb - originals store another backup) and normally the game would recognize that as "one half of the storage doesn't work" and display a message like "the save file has been corrupted. The previous save (meaning the backup) will be loaded". Counterfeiters patch this message to something like "the game can be played" in order to not alert the player. Fake games also very often omit the RTC-chip (to save money), so the clock will not be running in the game.

    * If the clock in the player's room *does* change over time and the tide in shoal cave changes, but berries don't grow, chances are that the battery has been replaced at some point, but there hasn't been a new savegame, afterwards. The savegame stores the highest seen rtc value and doesn't update berrys etc. if the value from the RTC-chip is lower.

    DS games take their clock from the DS itself and should work as long as the DS displays changing times. If the DS does not, there is something wrong with your console. If the game displays that error message, you should - again - check whether you got an original game or a counterfeit one.

    User Info: TCCPhreak

    TCCPhreak - 3 years ago 0 0
  11. This happens to me in crystal my clock is stuck at 7:01 I am playing on my black berry

    User Info: tyranity

    tyranity - 1 year ago 0 0

This question has been successfully answered and closed.

More Questions from This Game