Why doesn't the game let me fight the last battle of the Quest?

  1. (Ok, I'm befuddled. I have tried about 10 times to get through the Liberation of Skyrim [Civil War Quests] from) returning to Ulfric after victory over Windhelm. (This is the way the Internet says to do it); To Liberate Falkreath, you must complete Rescue From Fort Neugrad. (I went there but could never meet up with whatshisname before entering the fort - I even tried going to the consol to say sneak into fort complete)

    Upon completing that quest and returning to Ulfric, you must help liberate The Reach. (but I get sent to the Rift and then fort Hraggstad) (So I cannot do) ...visit the Stormcloaks' camp in The Reach and complete the quests Compelling Tribute and The Battle For Fort Sungard. (Nothing works after I complete fort Hraggstad After that fort is taken every BODY disappears)

    (I never get ) Return once again to Ulfric to earn your promotion and another token of his gratitude. Your intervention has been instrumental in gaining ground in this war. Continuing on, you are to now drop by the Hjaalmarch Stormcloak Camp and receive further instructions from Galmar. This begins A False Front, which then leads to The Battle For Fort Snowhawk.

    (So what the heck should I do!?)

    User Info: jefmeyer

    jefmeyer - 5 years ago


  1. Well, considering you know a lot about this, I'm guessing you've played the questline before or at least looked at the Elder Scrolls Wiki. All I can think of is load a previous save before that quest.

    BTW, you might want to be a bit clearer in your question info, it confused me a bit.

    User Info: Mega_DS_Player

    Mega_DS_Player - 5 years ago 0 0

This question was asked more than 60 days ago with no accepted answer.

Answer this Question

You're browsing GameFAQs Answers as a guest. Sign Up for free (or Log In if you already have an account) to be able to ask and answer questions.